This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 838651 - No sound after upgrade to F17 on snd-hda-intel
No sound after upgrade to F17 on snd-hda-intel
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 13:32 EDT by Pablo Iranzo Gómez
Modified: 2013-10-21 09:51 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 09:51:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info output (15.68 KB, application/octet-stream)
2012-07-09 13:32 EDT, Pablo Iranzo Gómez
no flags Details
pulseaudio -vvvvv output (38.49 KB, text/x-log)
2012-07-11 03:08 EDT, Pablo Iranzo Gómez
no flags Details
New log after removing esd and commenting lines in default.pa (33.71 KB, text/x-log)
2012-07-11 04:53 EDT, Pablo Iranzo Gómez
no flags Details
getfacl and systemd-loginctl with working sound, systemd-44-8 (1.95 KB, text/plain)
2012-07-11 12:42 EDT, Eric Smith
no flags Details
getfacl and systemd-loginctl with broken sound, systemd-44-17 (1.62 KB, text/plain)
2012-07-11 12:43 EDT, Eric Smith
no flags Details
/etc/pam.d/system-auth-ac (same for both 44-8 working and 44-17 nonworking) (990 bytes, text/plain)
2012-07-11 16:22 EDT, Eric Smith
no flags Details
pulseaudio -vvvvv output after modprobe.d/snd-hda-intel (104.69 KB, text/x-log)
2012-07-11 18:32 EDT, Pablo Iranzo Gómez
no flags Details

  None (edit)
Description Pablo Iranzo Gómez 2012-07-09 13:32:57 EDT
Created attachment 597116 [details]
alsa-info output

Description of problem:

After upgrade to F17 no sound output

Version-Release number of selected component (if applicable):

Kernel: 3.4.4-5.fc17.x86_64
Pulseaudio: pulseaudio-1.1-9.fc17.x86_64

How reproducible:


Steps to Reproduce:
1. Start system
2. Try to play a sound or check volume controls
3. No HW is displayed under gnome's sound configuration HW
  
Actual results:

No sound

Expected results:

Having sound as I had with F16

Additional info:
Comment 1 Eric Smith 2012-07-10 19:26:43 EDT
I upgraded an F16 system (which had been a fresh install) to F17, then did a "yum update", and then discovered this problem.  Pulseaudio shows no devices other than the null devices.

I tried doing a fresh install of F17 (w/o updates) on the same machine, and sound worked fine.  Then I did a "yum update", and am back to having no devices.

Thinking that it might be the kernel, I rebooted to the original F17 3.3.4-5 kernel, but still no devices.  I think it must have been broken by one of the other 419 packages that "yum update" updated, but I don't know how to track it down in any reasonable amount of time.

I'm just using the motherboard HDA sound, which worked fine on F16 and unupdated F17.  lspci | grep audio shows:

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
Comment 2 Eric Smith 2012-07-11 02:44:40 EDT
I verified that after doing a "yum history undo" to roll back the previous "yum upgrade", so that I am back to the original F17 package set, the sound works again.  Something in the updates repository other than the kernel is responsible for breaking the sound.
Comment 4 Eric Smith 2012-07-11 02:49:23 EDT
Thanks, but as I commented on that one, my pam stuff is fine.  In any case, if that was the problem, F17 without updates wouldn't work.  The situation I have is that fresh F17 works, but with updates fails.
Comment 5 Brendan Jones 2012-07-11 02:56:41 EDT
(In reply to comment #4)
> Thanks, but as I commented on that one, my pam stuff is fine.  In any case,
> if that was the problem, F17 without updates wouldn't work.  The situation I
> have is that fresh F17 works, but with updates fails.

I'm not sure your logic is correct there - this affects upgrades only 

Next time you upgrade can you perform the following:

rm -rf .pulse/*
pulseaudio --kill; pulseaudio -vvvv

And post the output here?
Comment 6 Pablo Iranzo Gómez 2012-07-11 03:08:14 EDT
I've tried several times, and I even reinstalled F17 from a clean state and experienced the same situation as  #2 and #4.

I'm attaching my output of pusealudi -vvvvv
Comment 7 Pablo Iranzo Gómez 2012-07-11 03:08:48 EDT
Created attachment 597473 [details]
pulseaudio -vvvvv output
Comment 8 Eric Smith 2012-07-11 03:27:41 EDT
In reply to comment 5:

I did a fresh install of F16 months ago.  I did an upgrade to F17 yesterday, followed immediately by a "yum update", and the sound was broken.  However, the pam_systemd stuff was correct, so the Common F17 Bug #815413 is *NOT* implicated.

This is further verified by the problem occurring in a completely different situation which involved NO upgrades from F16 or earlier.  I described this previously above, but apparently it wasn't sufficiently clear for you to understand, so I'll try again.  The sequence of events was:

I did a fresh install of F17 (NOT an upgrade from F16 or earlier), without the updates repository, and the sound worked fine.

Then I did a "yum update", and the sound broke.  The pam systemd stuff is still correct, so that is NOT the problem.

Then I did a "yum history undo", to get back to the original F17 package set with no updates, and sound worked again.
Comment 9 Brendan Jones 2012-07-11 04:09:27 EDT
(In reply to comment #8)
> This is further verified by the problem occurring in a completely different
> situation which involved NO upgrades from F16 or earlier.  I described this
> previously above, but apparently it wasn't sufficiently clear for you to
> understand, so I'll try again.  The sequence of events was:

No it wasn't sufficiently clear enough because neither did you once mention anything to do with PAM in this report nor did you quote the relevant common bug.
.

(In reply to comment #7)
> Created attachment 597473 [details]
> pulseaudio -vvvvv output

Thanks, I notice there is still some stream information in ~/.pulse Can you do 
rm -rf ~/.pulse/*

Can you list the contents of /etc/pulse ? 

and also ls -al /dev/snd/pcm as the normal user
Comment 10 Pablo Iranzo Gómez 2012-07-11 04:14:44 EDT
[iranzo@Deneb ~]$ ls -l /etc/pulse/
total 20
-rw-r--r--. 1 root root 1269 abr 22 00:57 client.conf
-rw-r--r--. 1 root root 2299 jul  9 14:41 daemon.conf
-rw-r--r--. 1 root root 5550 abr 22 00:57 default.pa
-rw-r--r--. 1 root root 2284 abr 22 00:57 system.pa
[iranzo@Deneb ~]$ rpm -qf /etc/pulse/*
pulseaudio-libs-1.1-9.fc17.x86_64
pulseaudio-1.1-9.fc17.x86_64
pulseaudio-1.1-9.fc17.x86_64
pulseaudio-1.1-9.fc17.x86_64
[iranzo@Deneb ~]$ rpm -V pulseaudio pulseaudio-libs
.......T.  c /etc/pulse/daemon.conf
[iranzo@Deneb ~]$ 



[iranzo@Deneb ~]$ ls -al /dev/snd/
total 0
drwxr-xr-x.  3 root root      140 jul  9 20:38 .
drwxr-xr-x. 21 root root     3740 jul 11 10:12 ..
drwxr-xr-x.  2 root root       60 jul  9 20:38 by-path
crw-rw----+  1 root audio 116,  3 jul  9 20:38 controlC0
crw-rw----+  1 root audio 116,  2 jul  9 20:38 hwC0D0
crw-rw----.  1 root audio 116,  1 jul  9 20:38 seq
crw-rw----+  1 root audio 116, 33 jul  9 20:38 timer




And repeatting the pulseaudio -vvvv:
[iranzo@Deneb ~]$ rm -rf .pulse/*
[iranzo@Deneb ~]$ pulseaudio --kill; pulseaudio -vvvvv
E: [pulseaudio] main.c: No se ha podido detener el demonio: No existe el proceso
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) falló: Operación no permitida
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) falló: Operación no permitida
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
I: [pulseaudio] core-util.c: Failed to acquire high-priority scheduling: Permiso denegado
I: [pulseaudio] main.c: Esto es PulseAudio 1.1
D: [pulseaudio] main.c: Host de compilación: x86_64-redhat-linux-gnu
D: [pulseaudio] main.c: Compilación CFLAGS: -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m64 -mtune=generic -W -Wextra -Wno-long-long -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -fno-common -fdiagnostics-show-option
D: [pulseaudio] main.c: Ejecutándose en el host: Linux x86_64 3.4.4-5.fc17.x86_64 #1 SMP Thu Jul 5 20:20:59 UTC 2012
D: [pulseaudio] main.c: Se encontraron 2 CPUs.
I: [pulseaudio] main.c: El tamaño de la página es de 4096 bytes
D: [pulseaudio] main.c: Soporte para compilar con Valgrind: no
D: [pulseaudio] main.c: Ejecutándose en modo valgrind: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Build optimizado: si
D: [pulseaudio] main.c: Todos los chequeos habilitados.
I: [pulseaudio] main.c: El ID de la máquina es 3f21dd4be017160d060407ac00000018
I: [pulseaudio] main.c: Utilizando directorio de tiempo de ejecución /home/iranzo/.pulse/3f21dd4be017160d060407ac00000018-runtime.
I: [pulseaudio] main.c: Utilizando directorio de estado /home/iranzo/.pulse.
I: [pulseaudio] main.c: Utilizando directorio de módulos /usr/lib64/pulse-1.1/modules.
I: [pulseaudio] main.c: Ejecutándose en modo de sistema: no
I: [pulseaudio] main.c: ¡Existen cronómetros de alta resolución fresquitos y disponibles! ¡Bon appetit!
D: [pulseaudio] memblock.c: Using shared memory pool with 1024 slots of size 64,0 KiB each, total size is 64,0 MiB, maximum usable slot size is 65472
I: [pulseaudio] cpu-x86.c: CPU flags: CMOV MMX SSE SSE2 SSE3 
I: [pulseaudio] svolume_mmx.c: Initialising MMX optimized volume functions.
I: [pulseaudio] remap_mmx.c: Initialising MMX optimized remappers.
I: [pulseaudio] svolume_sse.c: Initialising SSE2 optimized volume functions.
I: [pulseaudio] remap_sse.c: Initialising SSE2 optimized remappers.
I: [pulseaudio] sconv_sse.c: Initialising SSE2 optimized conversions.
D: [pulseaudio] database-tdb.c: Opened TDB database '/home/iranzo/.pulse/3f21dd4be017160d060407ac00000018-device-volumes.tdb'
I: [pulseaudio] module-device-restore.c: Successfully opened database file '/home/iranzo/.pulse/3f21dd4be017160d060407ac00000018-device-volumes'.
I: [pulseaudio] module.c: Loaded "module-device-restore" (index: #0; argument: "").
D: [pulseaudio] database-tdb.c: Opened TDB database '/home/iranzo/.pulse/3f21dd4be017160d060407ac00000018-stream-volumes.tdb'
I: [pulseaudio] module-stream-restore.c: Successfully opened database file '/home/iranzo/.pulse/3f21dd4be017160d060407ac00000018-stream-volumes'.
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1 added for object /org/pulseaudio/stream_restore1
I: [pulseaudio] module.c: Loaded "module-stream-restore" (index: #1; argument: "").
D: [pulseaudio] database-tdb.c: Opened TDB database '/home/iranzo/.pulse/3f21dd4be017160d060407ac00000018-card-database.tdb'
I: [pulseaudio] module-card-restore.c: Successfully opened database file '/home/iranzo/.pulse/3f21dd4be017160d060407ac00000018-card-database'.
I: [pulseaudio] module.c: Loaded "module-card-restore" (index: #2; argument: "").
I: [pulseaudio] module.c: Loaded "module-augment-properties" (index: #3; argument: "").
D: [pulseaudio] cli-command.c: Checking for existence of '/usr/lib64/pulse-1.1/modules/module-udev-detect.so': success
D: [pulseaudio] module-udev-detect.c: /dev/snd/controlC0 is accessible: yes
D: [pulseaudio] module-udev-detect.c: /devices/pci0000:00/0000:00:1b.0/sound/card0 is busy: no
D: [pulseaudio] module-udev-detect.c: Loading module-alsa-card with arguments 'device_id="0" name="pci-0000_00_1b.0" card_name="alsa_card.pci-0000_00_1b.0" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes card_properties="module-udev-detect.discovered=1"'
D: [pulseaudio] dbus-util.c: Successfully connected to D-Bus session bus ca476cad55fb9434bc379b780000902c as :1.0
D: [pulseaudio] reserve-wrap.c: Successfully acquired reservation lock on device 'Audio0'
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-mono
D: [pulseaudio] alsa-mixer.c: Checking for playback on Mono Analógico (analog-mono)
D: [pulseaudio] alsa-util.c: Trying hw:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device hw:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-mono+input:analog-mono
D: [pulseaudio] alsa-mixer.c: Checking for playback on Mono Analógico (analog-mono)
D: [pulseaudio] alsa-util.c: Trying hw:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device hw:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-mono+input:analog-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Mono Analógico (analog-mono)
D: [pulseaudio] alsa-util.c: Trying hw:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device hw:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-mono+input:iec958-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Mono Analógico (analog-mono)
D: [pulseaudio] alsa-util.c: Trying hw:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device hw:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Estéreo Analógico (analog-stereo)
D: [pulseaudio] alsa-util.c: Trying front:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device front:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-util.c: Trying hw:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device hw:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-stereo+input:analog-mono
D: [pulseaudio] alsa-mixer.c: Checking for playback on Estéreo Analógico (analog-stereo)
D: [pulseaudio] alsa-util.c: Trying front:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device front:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-util.c: Trying hw:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device hw:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-stereo+input:analog-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Estéreo Analógico (analog-stereo)
D: [pulseaudio] alsa-util.c: Trying front:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device front:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-util.c: Trying hw:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device hw:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-stereo+input:iec958-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Estéreo Analógico (analog-stereo)
D: [pulseaudio] alsa-util.c: Trying front:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device front:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-util.c: Trying hw:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device hw:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-40
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 4.0 (analog-surround-40)
D: [pulseaudio] alsa-util.c: Trying surround40:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround40:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-40+input:analog-mono
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 4.0 (analog-surround-40)
D: [pulseaudio] alsa-util.c: Trying surround40:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround40:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-40+input:analog-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 4.0 (analog-surround-40)
D: [pulseaudio] alsa-util.c: Trying surround40:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround40:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-40+input:iec958-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 4.0 (analog-surround-40)
D: [pulseaudio] alsa-util.c: Trying surround40:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround40:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-41
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 4.1 (analog-surround-41)
D: [pulseaudio] alsa-util.c: Trying surround41:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround41:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-41+input:analog-mono
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 4.1 (analog-surround-41)
D: [pulseaudio] alsa-util.c: Trying surround41:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround41:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-41+input:analog-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 4.1 (analog-surround-41)
D: [pulseaudio] alsa-util.c: Trying surround41:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround41:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-41+input:iec958-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 4.1 (analog-surround-41)
D: [pulseaudio] alsa-util.c: Trying surround41:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround41:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-50
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 5.0 (analog-surround-50)
D: [pulseaudio] alsa-util.c: Trying surround50:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround50:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-50+input:analog-mono
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 5.0 (analog-surround-50)
D: [pulseaudio] alsa-util.c: Trying surround50:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround50:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-50+input:analog-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 5.0 (analog-surround-50)
D: [pulseaudio] alsa-util.c: Trying surround50:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround50:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-50+input:iec958-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 5.0 (analog-surround-50)
D: [pulseaudio] alsa-util.c: Trying surround50:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround50:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-51
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 5.1 (analog-surround-51)
D: [pulseaudio] alsa-util.c: Trying surround51:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround51:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-51+input:analog-mono
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 5.1 (analog-surround-51)
D: [pulseaudio] alsa-util.c: Trying surround51:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround51:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-51+input:analog-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 5.1 (analog-surround-51)
D: [pulseaudio] alsa-util.c: Trying surround51:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround51:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-51+input:iec958-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Análogo Envolvente 5.1 (analog-surround-51)
D: [pulseaudio] alsa-util.c: Trying surround51:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround51:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-71
D: [pulseaudio] alsa-mixer.c: Checking for playback on Analog Surround 7.1 (analog-surround-71)
D: [pulseaudio] alsa-util.c: Trying surround71:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround71:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-71+input:analog-mono
D: [pulseaudio] alsa-mixer.c: Checking for playback on Analog Surround 7.1 (analog-surround-71)
D: [pulseaudio] alsa-util.c: Trying surround71:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround71:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-71+input:analog-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Analog Surround 7.1 (analog-surround-71)
D: [pulseaudio] alsa-util.c: Trying surround71:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround71:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-surround-71+input:iec958-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Analog Surround 7.1 (analog-surround-71)
D: [pulseaudio] alsa-util.c: Trying surround71:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device surround71:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:iec958-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Estéreo Digital (IEC958) (iec958-stereo)
D: [pulseaudio] alsa-util.c: Trying iec958:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D1p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device iec958:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:iec958-stereo+input:analog-mono
D: [pulseaudio] alsa-mixer.c: Checking for playback on Estéreo Digital (IEC958) (iec958-stereo)
D: [pulseaudio] alsa-util.c: Trying iec958:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D1p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device iec958:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:iec958-stereo+input:analog-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Estéreo Digital (IEC958) (iec958-stereo)
D: [pulseaudio] alsa-util.c: Trying iec958:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D1p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device iec958:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:iec958-stereo+input:iec958-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Estéreo Digital (IEC958) (iec958-stereo)
D: [pulseaudio] alsa-util.c: Trying iec958:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D1p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device iec958:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:iec958-ac3-surround-40
D: [pulseaudio] alsa-mixer.c: Checking for playback on Digital Envolvente 4.0 (IEC9588/AC3) (iec958-ac3-surround-40)
D: [pulseaudio] alsa-util.c: Trying a52:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm.c: Unknown PCM a52:0
I: [pulseaudio] alsa-util.c: Error opening PCM device a52:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:iec958-ac3-surround-40+input:analog-mono
D: [pulseaudio] alsa-mixer.c: Checking for playback on Digital Envolvente 4.0 (IEC9588/AC3) (iec958-ac3-surround-40)
D: [pulseaudio] alsa-util.c: Trying a52:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm.c: Unknown PCM a52:0
I: [pulseaudio] alsa-util.c: Error opening PCM device a52:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:iec958-ac3-surround-40+input:analog-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Digital Envolvente 4.0 (IEC9588/AC3) (iec958-ac3-surround-40)
D: [pulseaudio] alsa-util.c: Trying a52:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm.c: Unknown PCM a52:0
I: [pulseaudio] alsa-util.c: Error opening PCM device a52:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:iec958-ac3-surround-40+input:iec958-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Digital Envolvente 4.0 (IEC9588/AC3) (iec958-ac3-surround-40)
D: [pulseaudio] alsa-util.c: Trying a52:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm.c: Unknown PCM a52:0
I: [pulseaudio] alsa-util.c: Error opening PCM device a52:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:iec958-ac3-surround-51
D: [pulseaudio] alsa-mixer.c: Checking for playback on Digital Envolvente 5.1 (IEC958/AC3) (iec958-ac3-surround-51)
D: [pulseaudio] alsa-util.c: Trying a52:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm.c: Unknown PCM a52:0
I: [pulseaudio] alsa-util.c: Error opening PCM device a52:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:iec958-ac3-surround-51+input:analog-mono
D: [pulseaudio] alsa-mixer.c: Checking for playback on Digital Envolvente 5.1 (IEC958/AC3) (iec958-ac3-surround-51)
D: [pulseaudio] alsa-util.c: Trying a52:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm.c: Unknown PCM a52:0
I: [pulseaudio] alsa-util.c: Error opening PCM device a52:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:iec958-ac3-surround-51+input:analog-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Digital Envolvente 5.1 (IEC958/AC3) (iec958-ac3-surround-51)
D: [pulseaudio] alsa-util.c: Trying a52:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm.c: Unknown PCM a52:0
I: [pulseaudio] alsa-util.c: Error opening PCM device a52:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:iec958-ac3-surround-51+input:iec958-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Digital Envolvente 5.1 (IEC958/AC3) (iec958-ac3-surround-51)
D: [pulseaudio] alsa-util.c: Trying a52:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm.c: Unknown PCM a52:0
I: [pulseaudio] alsa-util.c: Error opening PCM device a52:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:hdmi-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Estéreo Digital (HDMI) (hdmi-stereo)
D: [pulseaudio] alsa-util.c: Trying hdmi:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D3p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device hdmi:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:hdmi-stereo+input:analog-mono
D: [pulseaudio] alsa-mixer.c: Checking for playback on Estéreo Digital (HDMI) (hdmi-stereo)
D: [pulseaudio] alsa-util.c: Trying hdmi:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D3p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device hdmi:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:hdmi-stereo+input:analog-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Estéreo Digital (HDMI) (hdmi-stereo)
D: [pulseaudio] alsa-util.c: Trying hdmi:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D3p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device hdmi:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile output:hdmi-stereo+input:iec958-stereo
D: [pulseaudio] alsa-mixer.c: Checking for playback on Estéreo Digital (HDMI) (hdmi-stereo)
D: [pulseaudio] alsa-util.c: Trying hdmi:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D3p' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device hdmi:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile input:analog-mono
D: [pulseaudio] alsa-mixer.c: Checking for recording on Mono Analógico (analog-mono)
D: [pulseaudio] alsa-util.c: Trying hw:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0c' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device hw:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile input:analog-stereo
D: [pulseaudio] alsa-mixer.c: Checking for recording on Estéreo Analógico (analog-stereo)
D: [pulseaudio] alsa-util.c: Trying front:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0c' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device front:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-util.c: Trying hw:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0c' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device hw:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Looking at profile input:iec958-stereo
D: [pulseaudio] alsa-mixer.c: Checking for recording on Estéreo Digital (IEC958) (iec958-stereo)
D: [pulseaudio] alsa-util.c: Trying iec958:0 with SND_PCM_NO_AUTO_FORMAT ...
I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D1c' failed (-2)
I: [pulseaudio] alsa-util.c: Error opening PCM device iec958:0: No existe el fichero o el directorio
D: [pulseaudio] alsa-mixer.c: Profile set 0x1a7d6c0, auto_profiles=yes, probed=yes, n_mappings=0, n_profiles=0, n_decibel_fixes=0
E: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
E: [pulseaudio] module.c: Failed to load module "module-alsa-card" (argument: "device_id="0" name="pci-0000_00_1b.0" card_name="alsa_card.pci-0000_00_1b.0" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes card_properties="module-udev-detect.discovered=1""): initialization failed.
I: [pulseaudio] module-udev-detect.c: Card /devices/pci0000:00/0000:00:1b.0/sound/card0 (alsa_card.pci-0000_00_1b.0) failed to load module.
I: [pulseaudio] module-udev-detect.c: Found 1 cards.
I: [pulseaudio] module.c: Loaded "module-udev-detect" (index: #4; argument: "").
D: [pulseaudio] cli-command.c: Checking for existence of '/usr/lib64/pulse-1.1/modules/module-jackdbus-detect.so': success
D: [pulseaudio] dbus-util.c: Successfully connected to D-Bus session bus ca476cad55fb9434bc379b780000902c as :1.1
D: [pulseaudio] module-jackdbus-detect.c: jackdbus isn't running.
I: [pulseaudio] module.c: Loaded "module-jackdbus-detect" (index: #5; argument: "").
D: [pulseaudio] cli-command.c: Checking for existence of '/usr/lib64/pulse-1.1/modules/module-bluetooth-discover.so': success
D: [pulseaudio] dbus-util.c: Successfully connected to D-Bus system bus e8f5062544b413b3b322627a0000001d as :1.202
D: [pulseaudio] bluetooth-util.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
D: [pulseaudio] bluetooth-util.c: Registering /MediaEndpoint/HFPAG on adapter /org/bluez/695/hci0.
D: [pulseaudio] bluetooth-util.c: Registering /MediaEndpoint/A2DPSource on adapter /org/bluez/695/hci0.
D: [pulseaudio] bluetooth-util.c: Registering /MediaEndpoint/A2DPSink on adapter /org/bluez/695/hci0.
I: [pulseaudio] bluetooth-util.c: Couldn't register endpoint /MediaEndpoint/A2DPSink, because BlueZ is configured to disable the endpoint type.
I: [pulseaudio] module.c: Loaded "module-bluetooth-discover" (index: #6; argument: "").
D: [pulseaudio] cli-command.c: Checking for existence of '/usr/lib64/pulse-1.1/modules/module-esound-protocol-unix.so': success
E: [pulseaudio] socket-server.c: bind(): La dirección ya se está usando
E: [pulseaudio] module.c: Failed to load module "module-esound-protocol-unix" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Fallo al intentar iniciar el demonio.
I: [pulseaudio] module.c: Unloading "module-device-restore" (index: #0).
I: [pulseaudio] module.c: Unloaded "module-device-restore" (index: #0).
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
I: [pulseaudio] module.c: Unloading "module-stream-restore" (index: #1).
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1 removed from object /org/pulseaudio/stream_restore1
I: [pulseaudio] module.c: Unloaded "module-stream-restore" (index: #1).
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
I: [pulseaudio] module.c: Unloading "module-card-restore" (index: #2).
I: [pulseaudio] module.c: Unloaded "module-card-restore" (index: #2).
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
I: [pulseaudio] module.c: Unloading "module-augment-properties" (index: #3).
I: [pulseaudio] module.c: Unloaded "module-augment-properties" (index: #3).
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
I: [pulseaudio] module.c: Unloading "module-udev-detect" (index: #4).
I: [pulseaudio] module.c: Unloaded "module-udev-detect" (index: #4).
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
I: [pulseaudio] module.c: Unloading "module-jackdbus-detect" (index: #5).
I: [pulseaudio] module.c: Unloaded "module-jackdbus-detect" (index: #5).
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
I: [pulseaudio] module.c: Unloading "module-bluetooth-discover" (index: #6).
I: [pulseaudio] module.c: Unloaded "module-bluetooth-discover" (index: #6).
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
I: [pulseaudio] main.c: El demonio se ha apagado.
Comment 11 Eric Smith 2012-07-11 04:27:52 EDT
Re #9:
> No it wasn't sufficiently clear enough because neither did you once mention 
> anything to do with PAM in this report nor did you quote the relevant common
> bug.

You mentioned that bug.  I said that the problem had occurred after a fresh install of F17 plus updates.  That should have been sufficient to make it clear that the problem was not with an F16 to F17 upgrade.

Currently my sound is working, and I'm experimenting with selectively upgrading things.  If/when I get it back into the broken state, I'll list /etc/pulse and such, and see how they compare to Pablo's.
Comment 12 Brendan Jones 2012-07-11 04:46:16 EDT
Can you try rm -rf /tmp/.esd*

and confirm that your user belongs to the audio group

groups

and post output again.

If it fails on  module-esound-protocol-unix try commenting out this line in /etc/default.pa

load-module module-esound-protocol-unix
Comment 13 Pablo Iranzo Gómez 2012-07-11 04:52:32 EDT
[iranzo@Deneb ~]$ groups
iranzo disk audio

[root@Deneb ~]# rm -rvf /tmp/.esd*
directorio borrado: «/tmp/.esd-500»



### Load several protocols
#.ifexists module-esound-protocol-unix.so
#load-module module-esound-protocol-unix
#.endif
#load-module module-native-protocol-unix

Attaching new log (but still no sound)
Comment 14 Pablo Iranzo Gómez 2012-07-11 04:53:08 EDT
Created attachment 597506 [details]
New log after removing esd and commenting lines in default.pa
Comment 15 Eric Smith 2012-07-11 05:03:11 EDT
OK, this yum update of systemd, systemd-sysv, and nfs-utils (updated to satisfy a dependency of the systemd packages) is what broke my sound:

Packages Altered:
    Updated nfs-utils-1:1.2.5-15.fc17.x86_64 @fedora
    Update            1:1.2.6-3.fc17.x86_64  @updates
    Updated systemd-44-8.fc17.x86_64         @fedora
    Update          44-17.fc17.x86_64        @updates
    Updated systemd-sysv-44-8.fc17.x86_64    @fedora
    Update               44-17.fc17.x86_64   @updates

Before that update, my sound worked.  After doing that update, Pulseaudio tells me that I have no sound devices other than the null devices.

I'm not sure whether to change the component for this bug to systemd.  Perhaps it's a moot point since Lennart is the developer for both.
Comment 16 Eric Smith 2012-07-11 05:08:50 EDT
I verified that using "yum history undo" to revert the update I described in comment 15 makes sound work on my system again.

So, is there anything specific I can do to help track down what in the update is causing this?
Comment 17 Brendan Jones 2012-07-11 06:32:54 EDT
Can you both humor me and post the output of 

getfacl /dev/snd/*

and 

getfacl /dev/snd/*
Comment 18 Brendan Jones 2012-07-11 06:33:12 EDT
Sorry, second was 

systemd-loginctl
Comment 19 Pablo Iranzo Gómez 2012-07-11 06:36:31 EDT
[iranzo@Deneb ~]$ getfacl /dev/snd/*;systemd-loginctl 
getfacl: Eliminando '/' inicial en nombres de ruta absolutos
# file: dev/snd/by-path
# owner: root
# group: root
user::rwx
group::r-x
other::r-x

# file: dev/snd/controlC0
# owner: root
# group: audio
user::rw-
user:iranzo:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/hwC0D0
# owner: root
# group: audio
user::rw-
user:iranzo:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/seq
# owner: root
# group: audio
user::rw-
group::rw-
other::---

# file: dev/snd/timer
# owner: root
# group: audio
user::rw-
user:iranzo:rw-
group::rw-
mask::rw-
other::---

   SESSION        UID USER             SEAT            
         4        500 iranzo           seat0           
        24        500 iranzo                           

2 sessions listed.
[iranzo@Deneb ~]$
Comment 20 Eric Smith 2012-07-11 12:42:10 EDT
Created attachment 597623 [details]
getfacl and systemd-loginctl with working sound, systemd-44-8
Comment 21 Eric Smith 2012-07-11 12:43:13 EDT
Created attachment 597624 [details]
getfacl and systemd-loginctl with broken sound, systemd-44-17
Comment 22 Eric Smith 2012-07-11 12:47:05 EDT
Apparently I get a login session when using systemd-44-8 but not with systemd-44-17.  That seems to be different than the problem Pablo has; do you want me to create a separate bug?  Is there anything else I can do to help further debug this?

Thanks!
Eric
Comment 23 Brendan Jones 2012-07-11 15:36:31 EDT
Eric, no that's fine. Clearly you don't have the required ACL's to access the device nodes. Can you please verify the contents of the /etc/pam.d directory? (system-auth.rpmnew) I know you mentioned that it was OK but it won't hurt to check again just to be sure.

If there is, it needs to be sysmlinked to /etc/pam.d/system-auth and run authconfig --updateall as you know
Comment 24 Brendan Jones 2012-07-11 16:06:38 EDT
(In reply to comment #19)
> [iranzo@Deneb ~]$ getfacl /dev/snd/*;systemd-loginctl 
> getfacl: Eliminando '/' inicial en nombres de ruta absolutos
> # file: dev/snd/by-path
...

Hi Pablo,

I'm thinking that for whatever reason the the hda-intel driver is not enumerating rour PCM nodes properly and you are not getting a working profile (there should be more /dev/pcm* nodes)

I'm largely guessing here, because it doesn't seem to be a pulse problem..

You could try modprobe -r snd-hda-intel

Add the following lines to /etc/modprobe.d/snd-hda-intel.conf

options snd-hda-intel model=3stack
options snd-hda-intel enable_msi=1

or whatever model you think is appropriate for your ALC880 chip here:

http://www.kernel.org/doc/Documentation/sound/alsa/HD-Audio-Models.txt
Comment 25 Eric Smith 2012-07-11 16:15:38 EDT
Here's what I get from ls with systemd-44-8 and working sound:

  lrwxrwxrwx. 1 root root  14 Jul 10 14:37 system-auth -> system-auth-ac
  -rw-r--r--. 1 root root 990 Jul 10 14:56 system-auth-ac
  -rw-r--r--. 1 root root 735 May  9 03:21 system-auth.rpmnew

Here's what I get from ls with systemd-44-17 and broken sound:

  lrwxrwxrwx. 1 root root  14 Jul 10 14:37 system-auth -> system-auth-ac
  -rw-r--r--. 1 root root 990 Jul 10 14:56 system-auth-ac
  -rw-r--r--. 1 root root 735 May  9 03:21 system-auth.rpmnew

Note that system-auth.rpmnew is not a symlink in either case.  I've verified that the contents of system-auth-ac and system-auth.rpmnew are identical in both cases.

I'm surprised that the contents of a .rpmnew file should be significant in any w
ay, but I just did this (starting from systemd-44-17):

  [root@p1 pam.d]# ls -l system-auth*
  lrwxrwxrwx. 1 root root  14 Jul 10 14:37 system-auth -> system-auth-ac
  -rw-r--r--. 1 root root 990 Jul 11 14:07 system-auth-ac
  -rw-r--r--. 1 root root 735 May  9 03:21 system-auth.rpmnew
  [root@p1 pam.d]# mv system-auth.rpmnew{,.bad}
  [root@p1 pam.d]# ln -s system-auth system-auth.rpmnew
  [root@p1 pam.d]# ls -l system-auth*
  lrwxrwxrwx. 1 root root  14 Jul 10 14:37 system-auth -> system-auth-ac
  -rw-r--r--. 1 root root 990 Jul 11 14:07 system-auth-ac
  lrwxrwxrwx. 1 root root  11 Jul 11 14:08 system-auth.rpmnew -> system-auth
  -rw-r--r--. 1 root root 735 May  9 03:21 system-auth.rpmnew.bad
  [root@p1 pam.d]# authconfig --updateall

Result: sound still doesn't work, systemd-loginctl still shows no session.

Reverted to systemd-44-8, and sound works, and systemd-loginctl shows a session.
Comment 26 Eric Smith 2012-07-11 16:22:59 EDT
Created attachment 597665 [details]
/etc/pam.d/system-auth-ac (same for both 44-8 working and 44-17 nonworking)
Comment 27 Eric Smith 2012-07-11 16:47:01 EDT
Grabbed the earlier systemd updates from Bodhi.  With systemd-44-12, I get a session and sound works.  With systemd-44-14, I don't get a session, and sound does not work.  It doesn't appear that an update was pushed for systemd-44-13, but I'll get it from Koji and give it a try.
Comment 28 Eric Smith 2012-07-11 16:58:27 EDT
systemd-44-13 fails for me, 44-12 works.  THe changelog entry for 44-13 is:

* Wed Jun 13 2012 Michal Schmidt <mschmidt@redhat.com> - 44-13 
- Patches from upstream - Fixes to journald, logind, tmpfiles
- Documentation improvements, systemctl help 
- New config options for systemd, journal 
- Add systemd-readahead-analyze, systemd-debug-shell.service 
- Start using Type=idle 
- Fixes: #828007, #814424, #831132, #791098, #823815, fdo#50402, fdo#50671

It's unfortunate that so many changes are in a single update; I'm not sure that I can find time to try to isolate it further.
Comment 29 Pablo Iranzo Gómez 2012-07-11 18:32:09 EDT
(In reply to comment #24)
> (In reply to comment #19)
> > [iranzo@Deneb ~]$ getfacl /dev/snd/*;systemd-loginctl 
> > getfacl: Eliminando '/' inicial en nombres de ruta absolutos
> > # file: dev/snd/by-path
> ...
> 
> Hi Pablo,
> 
> I'm thinking that for whatever reason the the hda-intel driver is not
> enumerating rour PCM nodes properly and you are not getting a working
> profile (there should be more /dev/pcm* nodes)
> 
> I'm largely guessing here, because it doesn't seem to be a pulse problem..
> 
> You could try modprobe -r snd-hda-intel
> 
> Add the following lines to /etc/modprobe.d/snd-hda-intel.conf
> 
> options snd-hda-intel model=3stack
> options snd-hda-intel enable_msi=1


[  447.592383] snd_hda_intel 0000:00:1b.0: irq 40 for MSI/MSI-X
[  447.604314] ALSA sound/pci/hda/hda_codec.c:5099 autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[  447.604326] ALSA sound/pci/hda/hda_codec.c:5103    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[  447.604331] ALSA sound/pci/hda/hda_codec.c:5107    hp_outs=1 (0x19/0x0/0x0/0x0/0x0)
[  447.604335] ALSA sound/pci/hda/hda_codec.c:5108    mono: mono_out=0x0
[  447.604339] ALSA sound/pci/hda/hda_codec.c:5112    inputs:
[  447.604347] ALSA sound/pci/hda/hda_codec.c:5116  Rear Mic=0x18
[  447.604351] ALSA sound/pci/hda/hda_codec.c:5116  Front Mic=0x1b
[  447.604354] ALSA sound/pci/hda/hda_codec.c:5116  Line=0x1a
[  447.604357] ALSA sound/pci/hda/hda_codec.c:5118 
[  447.607207] ALSA sound/pci/hda/patch_realtek.c:1317 realtek: No valid SSID, checking pincfg 0x411111f0 for NID 0x1d
[  447.607212] ALSA sound/pci/hda/patch_realtek.c:1400 realtek: Enable default setup for auto mode as fallback
[  447.618687] input: HDA Intel Line as /devices/pci0000:00/0000:00:1b.0/sound/card0/input19
[  447.620021] input: HDA Intel Front Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input20
[  447.620183] input: HDA Intel Rear Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input21
[  447.620335] input: HDA Intel Line Out as /devices/pci0000:00/0000:00:1b.0/sound/card0/input22


(I'm attaching new pulseaudio -vvvv)

No HW devices listed in gnome volume control
[root@Deneb iranzo]# ls -l /dev/snd/
total 0
drwxr-xr-x. 2 root root       60 jul 12 00:28 by-path
crw-rw----+ 1 root audio 116,  6 jul 12 00:28 controlC0
crw-rw----+ 1 root audio 116,  5 jul 12 00:28 hwC0D0
crw-rw----+ 1 root audio 116,  4 jul 12 00:30 pcmC0D0c
crw-rw----+ 1 root audio 116,  3 jul 12 00:30 pcmC0D0p
crw-rw----+ 1 root audio 116,  2 jul 12 00:28 pcmC0D2c
crw-rw----. 1 root audio 116,  1 jul 12 00:22 seq
crw-rw----+ 1 root audio 116, 33 jul 12 00:22 timer


[root@Deneb ~]# getfacl /dev/snd/*
getfacl: Eliminando '/' inicial en nombres de ruta absolutos
# file: dev/snd/by-path
# owner: root
# group: root
user::rwx
group::r-x
other::r-x

# file: dev/snd/controlC0
# owner: root
# group: audio
user::rw-
user:iranzo:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/hwC0D0
# owner: root
# group: audio
user::rw-
user:iranzo:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC0D0c
# owner: root
# group: audio
user::rw-
user:iranzo:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC0D0p
# owner: root
# group: audio
user::rw-
user:iranzo:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC0D2c
# owner: root
# group: audio
user::rw-
user:iranzo:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/seq
# owner: root
# group: audio
user::rw-
group::rw-
other::---

# file: dev/snd/timer
# owner: root
# group: audio
user::rw-
user:iranzo:rw-
group::rw-
mask::rw-
other::---
Comment 30 Pablo Iranzo Gómez 2012-07-11 18:32:46 EDT
Created attachment 597677 [details]
pulseaudio -vvvvv output after modprobe.d/snd-hda-intel
Comment 31 Eric Smith 2012-07-11 18:38:31 EDT
systemd-44-13 has the same base sources as 44-12, but adds patches 339-411.  I did a bisection and found that patch 405 is the (first) one that breaks things for me.  I tried to build 44-13 with only patch 405 omitted, but then it fails to build due to the way that the spec uses git to apply the patches, which I don't understand.

Patch 405 is 0405-tmpfiles-allow-to-specify-basename-only-systemd-tmpf.patch

Looking at it gives me no clue as to what it does that prevents me from getting a login session.
Comment 32 Brendan Jones 2012-07-12 00:43:29 EDT
Pablo, I think we may be getting somewhere 

can you try 
options snd-hda-intel model=auto  

instead?
Comment 33 Brendan Jones 2012-07-12 00:46:06 EDT
Eric,

I think we should raise a bug against systemd on this. The commit mail is here for the patch in question:

http://cgit.freedesktop.org/systemd/systemd/commit/?id=9125670f9a3dc34adf16b87635b460b2e4099b78
Comment 34 Pablo Iranzo Gómez 2012-07-12 02:54:09 EDT
(In reply to comment #32)
> Pablo, I think we may be getting somewhere 
> 
> can you try 
> options snd-hda-intel model=auto  
> 
> instead?

With that value "auto" I get all values as '0', but with 3stack I was getting line out, hp outs, but no controls.

I changed the model to 6stack (as I was using 5.1 card) and put back default.pa without commenting the lines we commented before.

When I had some sound, I started playing to get sound from surround and frontal speaker and I had to reassing the speaker exit lines and the jacks (and finally, they match the colour of the jack with the color of the hole in the motherboard)...

So, now it works... how can I contribute to autodetect the model instead of specifying it (previous to F17 it worked that way).

Thanks
Pablo
Comment 35 Brendan Jones 2012-07-12 03:00:51 EDT
(In reply to comment #34)
> 
> So, now it works... how can I contribute to autodetect the model instead of
> specifying it (previous to F17 it worked that way).
> 
> Thanks
> Pablo

Not sure, I'll reassign to kernel/alsa and perhaps they can comment.
Comment 36 Eric Smith 2012-07-12 13:00:18 EDT
Since my problem apparently has a completely different root cause than Pablo's, I have created bug #839736 to track mine.
Comment 37 Pablo Iranzo Gómez 2012-12-04 05:52:04 EST
On Fedora 18 beta, I still need to specify the card to have working sound output...
Comment 38 Raymond 2013-01-22 01:25:43 EST
all alc880 need pin fixup  since bios did not set pin default

is this a desktop or notebook ?

how many audio jacks at rear panel ?


!!Sysfs Files
!!-----------

/sys/class/sound/hwC0D0/init_pin_configs:
0x14 0x00000000
0x15 0x00000000
0x16 0x00000000
0x17 0x00000000
0x18 0x00000000
0x19 0x00000000
0x1a 0x00000000
0x1b 0x00000000
0x1c 0x00000000
0x1d 0x00000000
0x1e 0x00000000
0x1f 0x00000000

/sys/class/sound/hwC0D0/driver_pin_configs:
Comment 39 Justin M. Forbes 2013-10-18 17:08:43 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 18 kernel bugs.

Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 19, and are still experiencing this issue, please change the version to Fedora 19.

If you experience different issues, please open a new bug report for those.
Comment 40 Pablo Iranzo Gómez 2013-10-20 16:45:12 EDT
I'm running F19 and problem is no longer present.

Note You need to log in before you can comment on or make changes to this bug.