Bug 838667 - [jboss-as-5] Queues and Topics do not provide some required default plug-in configuration values
[jboss-as-5] Queues and Topics do not provide some required default plug-in c...
Status: CLOSED DUPLICATE of bug 831513
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.4
All All
unspecified Severity high (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 14:07 EDT by Larry O'Leary
Modified: 2012-07-20 15:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: EMBJOPR-368
Environment:
Last Closed: 2012-07-20 15:18:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry O'Leary 2012-07-09 14:07:43 EDT
+++ This bug was initially created as a clone of Bug #838666 +++

Created attachment 597125 [details]
Log excerpt from agent log showing complete stack/failure for queue creation

Description of problem:
Try to create a queue or topic with only the two required properties name and JNDIName. This will fail with "vfsfile:/devel/jboss-eap-5.1/jboss-as/server/default/deploy/java__myT-service.xml -> org.jboss.deployment.DeploymentException: Error configuring attribute DLQ" 

Same happens for ExpiryQueue and ServerPeer.


Version-Release number of selected component (if applicable):
JON 3.1.0

How reproducible:
Always

Steps to Reproduce:
1. From the EAP 5 resource / Resources / JBoss Messaging - Inventory > Child Resources sub-tab, select Create Child -> Queue
2. Specify a resource name and click Next
3. Specify a queue Name and JNDI Name and click Finish
  
Actual results:
Creation of queue is scheduled but fails due to (complete log excerpt attached):

*** DEPLOYMENTS IN ERROR: Name -> Error

vfsfile:/opt/jboss/eap/jboss-eap-5.1.2/jboss-eap-5.1/jboss-as/server/all/deploy/_queue_TestQueue-service.xml -> org.jboss.deployment.DeploymentException: Error configuring attribute DLQ


DEPLOYMENTS IN ERROR:
  Deployment "vfsfile:/opt/jboss/eap/jboss-eap-5.1.2/jboss-eap-5.1/jboss-as/server/all/deploy/_queue_TestQueue-service.xml" is in error due to the following reason(s): javax.management.MalformedObjectNameException: Key properties cannot be empty



Expected results:
Creation of queue is scheduled and successfully deployed after specifying minimum required configuration properties.


Additional info:
This issue was originally identified in https://issues.jboss.org/browse/EMBJOPR-368 with the following recommended solution:

Those 3 properties need default values set like this:

<c:simple-property required="false" name="expiryQueue" default="jboss.messaging.destination:service=Queue,name=ExpiryQueue">

<c:simple-property required="false" name="DLQ" default="jboss.messaging.destination:service=Queue,name=DLQ">

<c:simple-property required="false" name="serverPeer" default="jboss.messaging:service=ServerPeer">
Comment 1 Larry O'Leary 2012-07-20 15:18:15 EDT

*** This bug has been marked as a duplicate of bug 831513 ***

Note You need to log in before you can comment on or make changes to this bug.