Bug 838726 - Failed deployments can't be removed
Failed deployments can't be removed
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Jan Provaznik
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 19:37 EDT by Justin Clift
Modified: 2015-07-13 00:35 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cloud Engine failed at some attempts to delete unsuccessfully launched applications. This caused the faulty application to remain indefinitely. This bug fix sets a CREATE_FAILED state for failed instances, which allows the deletion of failed applications.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:12:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screencast showing deployment removal problem. (8.07 MB, video/mp4)
2012-07-09 19:37 EDT, Justin Clift
no flags Details
Screenshot showing flash message about deployment not being delete-able. (194.84 KB, image/png)
2012-07-14 02:33 EDT, Justin Clift
no flags Details
History tab for the instance that refuses to go away. (202.02 KB, image/png)
2012-07-14 02:34 EDT, Justin Clift
no flags Details
Failed deployment listed (154.05 KB, image/png)
2012-09-21 15:49 EDT, Ronelle Landy
no flags Details
Failed deployement deleted (142.93 KB, image/png)
2012-09-21 15:50 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Justin Clift 2012-07-09 19:37:49 EDT
Created attachment 597180 [details]
Screencast showing deployment removal problem.

Description of problem:

  With upstream Aeolus 0.10.x rpms (on F16),
  it's not possible to remove failed deployments.

  For example, with a recent setup, I have 3 wordpress
  deployments which failed when being started up.

  All three completely refuse to go away, no matter
  what I try to do to delete them.

  Screencast showing the problem (.mp4) attached.
  The deployment instance history and other info tabs
  are shown in the screencast.


Version-Release number of selected component (if applicable):

  aeolus-all-0.10.4-1.fc16.noarch
  aeolus-conductor-0.10.4-1.fc16.noarch
  aeolus-conductor-daemons-0.10.4-1.fc16.noarch
  aeolus-conductor-devel-0.10.4-1.fc16.noarch
  aeolus-conductor-doc-0.10.4-1.fc16.noarch
  aeolus-configure-2.6.0-1.fc16.noarch
  rubygem-aeolus-cli-0.5.0-1.fc16.noarch
  rubygem-aeolus-image-0.5.0-1.fc16.noarch

How reproducible:

  Every time.


Steps to Reproduce:
1. Probably the easiest way to cause a failed
   deployment, is by manually removing a
   VMware image from the backend NFS storage,
   once it's been pushed.
2. After that, Aeolus will attempt to launch
   the deployment, but the instance with
   missing storage will be status
   "create_failed".  It's deployment will not
   be removable.
Comment 1 Jan Provaznik 2012-07-12 14:46:17 EDT
a patch sent: https://fedorahosted.org/pipermail/aeolus-devel/2012-July/011266.html
Comment 2 Jan Provaznik 2012-07-13 10:27:04 EDT
pushed to master, commits:
8290aa1cfef19e54252256ea84f81120f46a6b99
94b243ac4af6b416e48528457d8bb4b5bcdc05b6
Comment 3 Justin Clift 2012-07-14 02:32:58 EDT
Found a case where deployments still can be killed.  Screenshots attached showing the problem, the History tab for the instance in question, and the related error in the VMware screen that I think caused it.

Looks like a follow up patch is needed. ;)
Comment 4 Justin Clift 2012-07-14 02:33:47 EDT
Created attachment 598220 [details]
Screenshot showing flash message about deployment not being delete-able.
Comment 5 Justin Clift 2012-07-14 02:34:26 EDT
Created attachment 598221 [details]
History tab for the instance that refuses to go away.
Comment 6 Justin Clift 2012-07-23 04:36:47 EDT
s/still can be killed/still can't be killed/
Comment 7 Jan Provaznik 2012-07-24 08:24:21 EDT
the issue described in Comment 3 is not conductor-related, it's probably dc-api bug, created new bug for it here: https://issues.apache.org/jira/browse/DTACLOUD-287
Comment 9 Ronelle Landy 2012-09-21 15:49:11 EDT
Tested rpms:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

Created a failed deployment by launching an instance in a rhevm realm with no hosts to start the vm. I was able to delete the deployment from the /conductor/deployments page.

See the attached screenshots.

Marking this BZ as 'verified'
Comment 10 Ronelle Landy 2012-09-21 15:49:58 EDT
Created attachment 615603 [details]
Failed deployment listed
Comment 11 Ronelle Landy 2012-09-21 15:50:34 EDT
Created attachment 615604 [details]
Failed deployement deleted
Comment 13 errata-xmlrpc 2012-12-04 10:12:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.