Bug 838742 - [RFE] Add sha256sum to Anaconda runtime environment.
[RFE] Add sha256sum to Anaconda runtime environment.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.4
Unspecified Unspecified
medium Severity low
: rc
: 6.4
Assigned To: David Cantrell
Release Test Team
: FutureFeature, Triaged
Depends On:
Blocks: 755474 840685
  Show dependency treegraph
 
Reported: 2012-07-09 21:19 EDT by Platform RFE
Modified: 2013-02-21 05:00 EST (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.21.178-1
Doc Type: Enhancement
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:00:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Platform RFE 2012-07-09 21:19:51 EDT
** Original comment by rdassen@redhat.com **

3. What is the nature and description of the request?

Add sha256sum to Anaconda runtime environment.

        4. Why does the customer need this? (List the business requirements
        here):

RPM signatures are now generated by sha256sum instead of md5sum.  The
Anaconda runtime environment does not include sha256sum, but does include
md5sum.  Without sha256sum, it is not possible to manually verify package
signatures if there are package integrity problems in the Anaconda runtime
environment.

        5. How would the customer like to achieve this? (List the functional
        requirements here)

Include the sha256sum command line utility in anaconda such that it is
available in the shell during install.

        6. For each functional requirement listed in question 5, specify how
        Red Hat and the customer can test to confirm the requirement is
        successfully implemented.

Press ctrl-alt-f2 during an install to gain a shell prompt, run sha256sum
<some.rpm> and a sha256 sum is returned.

        7. Is there already an existing RFE upstream or in Red Hat bugzilla?

No

        8. Does the customer have any specific timeline dependencies?

No.

        9. Is the sales team involved in this request and do they have any
        additional input?

No.

        10. List any affected packages

coreutils

        11. Would the customer be able to assist in testing this
        functionality if implemented?

Customer testing should not be necessary.
Comment 9 Jesse Keating 2012-07-11 18:15:25 EDT
Patch posted.
Comment 10 Jesse Keating 2012-08-15 17:22:09 EDT
pushed upstream 
4bff56e69407e800504b5a1d6f6c8b7e920fec77
Comment 12 Jan Stodola 2012-12-10 07:08:34 EST
sha256sum is present in anaconda environment:

[anaconda root@rtt7 root]# which sha256sum    
/usr/bin/sha256sum
[anaconda root@rtt7 root]# dd if=/dev/zero bs=1M count=1 | sha256sum 
1+0 records in
1+0 records out
1048576 bytes (1.0 MB) copied, 0.00927672 s, 113 MB/s
30e14955ebf1352266dc2ff8067e68104607e750abb9d3b36582b8af909fcb58  -
[anaconda root@rtt7 root]#

Tested on build RHEL6.4-20121206.0 with anaconda-13.21.187-1.el6.

Moving to VERIFIED.
Comment 14 errata-xmlrpc 2013-02-21 05:00:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0373.html

Note You need to log in before you can comment on or make changes to this bug.