Bug 838746 - support multiple pids in set_pid_ftrace
support multiple pids in set_pid_ftrace
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: trace-cmd (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: 6.4
Assigned To: John Kacur
Guangze Bai
: FutureFeature
Depends On:
Blocks: 840683 769377
  Show dependency treegraph
 
Reported: 2012-07-09 21:21 EDT by Platform RFE
Modified: 2015-02-08 16:38 EST (History)
5 users (show)

See Also:
Fixed In Version: trace-cmd-1.0.5-9.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:32:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 Platform RFE 2012-07-09 21:21:41 EDT
** Original comment by snagar@redhat.com **

Description of problem:
1. Proposed title of this feature request
Support multiple pids in set_pid_ftrace


2. Who is the customer behind the request?
<Confidential>

3. What is the nature and description of the request?

Jiri Olsa submitted a patch back in '09 that makes it possible to filter ftrace data based on multiple pid's rather than only one.  I believe this patch is now upstream. This doesn't seem to be in RHEL6 yet so could you backport it?

https://lkml.org/lkml/2009/9/16/83

trace-cmd would also need to be adjusted accordingly and support multiple -P options:

trace-cmd record -p function -P 30192,16429

or, alternatively:

trace-cmd record -p function -P 30192 -P 16429

4. Why does the customer need this? (List the business requirements here)

It enhances the functionality of ftrace which they make extensive use of

5. How would the customer like to achieve this? (List the functional
requirements here)

Noted above

6. For each functional requirement listed in question 4, specify how Red Hat
and the customer can test to confirm the requirement is successfully
implemented.

The noted above should work

7. Is there already an existing RFE upstream or in Red Hat bugzilla?

No

8. Does the customer have any specific timeline dependencies?

No

9. Is the sales team involved in this request and do they have any additional input?
No


10. List any affected packages

kernel, trace-cmd
Comment 14 errata-xmlrpc 2013-02-21 05:32:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0423.html

Note You need to log in before you can comment on or make changes to this bug.