Bug 838816 - management network is misconfigured when setup other network.
management network is misconfigured when setup other network.
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.1 RC
Unspecified Unspecified
urgent Severity unspecified
: ---
: 3.2
Assigned To: Alona Kaplan
network
:
Depends On:
Blocks: ovirt-3.2-release
  Show dependency treegraph
 
Reported: 2012-07-10 04:21 EDT by Mark Wu
Modified: 2013-02-15 01:46 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 01:46:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
setunNetwork1 (35.27 KB, image/png)
2012-07-10 04:21 EDT, Mark Wu
no flags Details
setunNetwork2 (54.22 KB, image/png)
2012-07-10 04:22 EDT, Mark Wu
no flags Details

  None (edit)
Description Mark Wu 2012-07-10 04:21:34 EDT
Created attachment 597243 [details]
setunNetwork1

Description of problem:
When I tried to setup other network, webadmin also update the ovirtmgmt network with dhcp option even though I only checked in the nic which I want to setup network on. After this operation, engine lost connection to my vdsm host because the ip address of ovirtmgmt was changed.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-3.1.0-0.2.20120704git1df1ba.fc17.noarch

How reproducible:
always

Steps to Reproduce:
Please see the pictures attached.
  
Actual results:


Expected results:
In setupNetwork ui, other networks/devices except the ones to be setup should not be changed.

Additional info:
in vdsm.log,  I see:
Thread-159::DEBUG::2012-07-09 09:14:23,655::BindingXMLRPC::872::vds::(wrapper) client [192.168.122.1]::call setupNetworks with ({'ovirtmgmt': {'nic': 'eth1', 'bootproto': 'dhcp', 'bridged': 'true'}}...
Comment 1 Mark Wu 2012-07-10 04:22:07 EDT
Created attachment 597244 [details]
setunNetwork2
Comment 2 Mark Wu 2012-07-10 04:24:20 EDT
please note that in picture setunNetwork2,  the option of ovirtmgmt was not chosen  by me. I just want show up it's set by engine automatically.
Comment 3 Mark Wu 2012-07-10 04:26:59 EDT
To work around this problem,  I have to change the bootproto option back to 'static' for ovirtmgmt manually every time I edit other networks.
Comment 4 Justin Clift 2012-08-09 19:12:11 EDT
Manually configuring the bridged interfaces on each host, then removing the:

  /var/lib/vdsm/netconfback

directory, allowed vdsmd to start ok, and have the network interfaces function properly.

Not daring to go back into the logical network configuration screen in the oVirt UI though, just in case it wipes things out again.
Comment 5 Tom Scofield 2012-11-02 22:05:11 EDT
I am running into this same issue using package ovirt-engine-webadmin-portal-3.1.0-3.19.el6.noarch installed via RPM from the http://www.dreyou.org/ovirt/ repo.  Any time I go into the "Setup Hosts Networks" the network configuration gets reset to some defaults.  The ovirtmgmt network get set to DHCP and any bonded device get set to bond mode 4.  I can only change one network configuration item, and only the last one made seems to take effect.  If I change the ovirtmgmt network to static, my bonded interface looses its mode 1 setting and VM traffic fails.  If I change the bond mode to 1 my ovirtmgmt interface gets set to dhcp.  Also, hitting cancel instead of ok on the page still causes the interfaces to get messed up.

There seem to be some changes to this page in the head of the code, can we expect these changes to be merged into the 3.1 branch?
Comment 6 Alona Kaplan 2012-12-11 07:15:54 EST
fixed in commit- 3d97d9c3a3c4dc46162d63811ebee5cc20287e38
Comment 7 Itamar Heim 2013-01-16 11:09:48 EST
3.2 beta built, moving to ON_QA status to allow testing
Comment 8 Tom Scofield 2013-02-02 15:08:10 EST
I was not able to reproduce this issue with a recent 3.2 nightly build.

Note You need to log in before you can comment on or make changes to this bug.