Bug 838871 - Apply button is always clickable
Apply button is always clickable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fonts-tweak-tool (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 06:30 EDT by Akira TAGOH
Modified: 2012-08-09 19:27 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.0.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 19:27:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2012-07-10 06:30:01 EDT
Description of problem:
This behavior mislead that the changes may be not applied.

Version-Release number of selected component (if applicable):
fonts-tweak-tool-0.0.6-1.fc17.noarch

How reproducible:
always

Steps to Reproduce:
1.run fonts-tweak-tool
2.
3.
  
Actual results:
Apply button is clickable regardless of something is changed.

Expected results:
it should be reflected according to the current status

Additional info:
Comment 1 James Ni 2012-07-24 00:18:26 EDT
Hi tagoh

I have remove the "Close" button and change "Apply" button to "OK"

The "OK" button will show a pop up window to warn that changes will write to configuration file, when there is changes. The changes include add/remove one language to/from list, or remove all the language. 

If there is no changes, press "OK" button just close the window.

https://github.com/jamesni/fonts-tweak-tool/commit/df9aa2255baa4337bcda6267a1de2e46a1e334bb

I will include this change in new release 0.0.7. 

Thanks
Comment 2 Fedora Update System 2012-07-24 22:20:44 EDT
fonts-tweak-tool-0.0.7-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/fonts-tweak-tool-0.0.7-1.fc16
Comment 3 Fedora Update System 2012-07-24 22:21:11 EDT
fonts-tweak-tool-0.0.7-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fonts-tweak-tool-0.0.7-1.fc17
Comment 4 Akira TAGOH 2012-07-24 23:30:19 EDT
I can still see this issue on Fonts tab with 0.0.7-1.fc17.

FWIW it looks like the dialog-wise window though, embedding the dialog buttons into the tab looks a bad idea.
Comment 5 Akira TAGOH 2012-07-24 23:40:20 EDT
I'm wondering if I should open another bug but it may be related to this. so just add a comment here.

Well, due to the thing as I mentioned in the above comment, if one do the following steps, the changes will be missed:

1. Add a language on GTK Language Order tab
2. Switch the tab to Fonts
3. Click the close button

As I told you on IRC, you better consider to use "instant apply".
Comment 6 Fedora Update System 2012-08-06 22:18:25 EDT
fonts-tweak-tool-0.0.8-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fonts-tweak-tool-0.0.8-1.fc17
Comment 7 Fedora Update System 2012-08-06 22:18:53 EDT
fonts-tweak-tool-0.0.8-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/fonts-tweak-tool-0.0.8-1.fc16
Comment 8 Fedora Update System 2012-08-09 19:06:01 EDT
Package fonts-tweak-tool-0.0.8-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fonts-tweak-tool-0.0.8-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11593/fonts-tweak-tool-0.0.8-1.fc16
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-08-09 19:27:02 EDT
fonts-tweak-tool-0.0.8-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.