Bug 8389 - sndconfig crashes machine with no PCI cards
sndconfig crashes machine with no PCI cards
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-11 19:17 EST by Stephen John Smoogen
Modified: 2014-03-16 22:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-05 01:17:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2000-01-11 19:17:19 EST
486 DX2 66
16 megs of RAM
SCSI Adaptec 1540 (base=0x330 irq=10)
  200 meg HD (ID 0)
  800 meg HD (ID 3)
  2x cdrom   (ID 6)
Etherlink III (base=0x300 irq=5)
MSBusmouse (irq 3)
MAD16 (Soundblaster compatible) Base=0x220 IRQ=7

running sndconfig caused the system to hard lockup with a kernel error
from the aha1540 card. I am guessing that it autoprobed something that
it shouldnt have :).

Better functionality might be to have an extra screen.

Welcome to Sound Config

Do you wish sndconfig to autoprobe for your SoundCard?
This may cause some machines to crash due to IO conflicts and other
problems.

<YES>  <NO>

Yes goes through the AUTOProbe code tree.. NO takes you through the
other one.
Comment 1 Stephen John Smoogen 2000-01-12 18:54:59 EST
First info:

sndconfig -noprobe -noautoconfig does not have this problem

pnpdump -c will cause this problem.

DMA information
0/1 MAD16 card
5   AHA1540

Ok problem seems to be with the Adaptec 1540 and PNP probes. The CP dies when a
PNP dump of any sort is done... sigh.
Comment 2 Bill Nottingham 2000-02-05 01:17:59 EST
Closing, as there's not much we can do in this case.
The hardware certainly shouldn't do that, and since it's
an ISA card, there's no way we can detect this. :(

Note You need to log in before you can comment on or make changes to this bug.