Bug 838906 - RHSC Displays a tab named DASHBOARD, that doesn't work
RHSC Displays a tab named DASHBOARD, that doesn't work
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kanagaraj
Prasanth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 08:17 EDT by Paul Cuzner
Modified: 2016-04-18 06:05 EDT (History)
8 users (show)

See Also:
Fixed In Version: qa4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shows the dashboard tab when looking at a bookmark'd display (153.90 KB, image/png)
2012-07-10 08:17 EDT, Paul Cuzner
no flags Details

  None (edit)
Description Paul Cuzner 2012-07-10 08:17:13 EDT
Created attachment 597322 [details]
Shows the dashboard tab when looking at a bookmark'd display

Description of problem:
When using bookmarks in rhsc, a tab called dashboard is visible on the right hand side of the GUI. Clicking on the tab results in an error.

Version-Release number of selected component (if applicable):
v2.0


How reproducible:
every time dashboard is selected, the error is shown.

Steps to Reproduce:
1. Open rhsc, and create a bookmark for a subset of the objects (e.g. several servers.
2. Go back to the normal tree view 
3. Open the book marks and select the one just created, the dashboard tab should become visible
4. click on the dashboard tab
  
Actual results:
error is output into the right hand pane

Expected results:
Either a dashboard should be shown or this tab should be removed

Additional info:
Attachments added showing the tab, when using a bookmark and also the resulting error when the tab is clicked.
Comment 2 Kanagaraj 2012-11-29 23:22:57 EST
patch sent to upstream: http://gerrit.ovirt.org/9598
Comment 3 Prasanth 2013-01-11 05:23:56 EST
Verified in Red Hat Storage Console Version: 2.1-0.qa4d.el6rhs.

Dashboard and Quota tabs are no more visible.
Comment 5 Scott Haines 2013-09-23 18:25:19 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.