Bug 838955 - Provider account "Role Assignments" shows incorrect page
Provider account "Role Assignments" shows incorrect page
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Tzu-Mainn Chen
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 09:49 EDT by Rehana
Modified: 2012-12-04 10:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A fault with the permissions tab selection meant clicking the Role Assignments for a Provider had no action. This fix corrects the behavior of the permissions tab selection. Users now have access to the Role Assignments for a Provider.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:12:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
provider_roles (194.89 KB, image/png)
2012-07-10 09:49 EDT, Rehana
no flags Details

  None (edit)
Description Rehana 2012-07-10 09:49:30 EDT
Created attachment 597346 [details]
provider_roles

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Aeolus installed on Fedora 16
2.Log in as admin
3.Go to cloud prvoiders
4.Click on "Role Assignments "
  
Actual results:
Observed that connectivity informations are displayed(PFa:provider_roles.png)

Expected results:
Should display the roles and users

Additional info:
rpm -qa | grep aeolus

aeolus-configure-2.7.0-0.20120709172029gite93c068.fc16.noarch
aeolus-conductor-0.11.0-0.20120709213339gitb6f79a1.fc16.noarch
aeolus-all-0.11.0-0.20120709213339gitb6f79a1.fc16.noarch
rubygem-aeolus-image-0.3.0-2.fc16.noarch
aeolus-conductor-daemons-0.11.0-0.20120709213339gitb6f79a1.fc16.noarch
aeolus-conductor-devel-0.11.0-0.20120709213339gitb6f79a1.fc16.noarch
rubygem-aeolus-cli-0.3.0-3.fc16.noarch
aeolus-conductor-doc-0.11.0-0.20120709213339gitb6f79a1.fc16.noarch
Comment 1 Tzu-Mainn Chen 2012-08-03 12:43:27 EDT
Patch created:

http://lists.fedorahosted.org/pipermail/aeolus-devel/2012-August/011837.html
Comment 2 Tzu-Mainn Chen 2012-08-03 13:02:41 EDT
Patch pushed to master:

commit c8e87f2f866a9e4639a68b86b35ae9a7a098d6fe
fix permissions tab select
Comment 3 Tzu-Mainn Chen 2012-08-03 13:12:44 EDT
Patch pushed to 1.1:

commit e82ee73160a134ed596622016255c1468eb02f54
fix permissions tab select
(cherry picked from commit c8e87f2f866a9e4639a68b86b35ae9a7a098d6fe)
Comment 5 Aziza Karol 2012-09-17 06:08:26 EDT
Provider account "Role Assignments" display correct page.

verified:
#rpm -qa | grep aeolus
aeolus-conductor-0.13.7-1.el6cf.noarch
aeolus-all-0.13.7-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.7-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.7-1.el6cf.noarch
Comment 7 errata-xmlrpc 2012-12-04 10:12:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.