Bug 83899 - message display broken
Summary: message display broken
Keywords:
Status: CLOSED DUPLICATE of bug 84593
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gtkhtml
Version: 1.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
: 83918 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-02-09 20:23 UTC by Tim Waugh
Modified: 2007-04-18 16:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:40 UTC


Attachments (Terms of Use)
This patch disable broken code (542 bytes, patch)
2003-02-11 17:02 UTC, Leonid Kanter
no flags Details | Diff
This patch for spec file fixes Russian and Ukrainian (2.94 KB, patch)
2003-02-11 17:08 UTC, Leonid Kanter
no flags Details | Diff
Underlines under icons are result of KOI8-R translation. (12.31 KB, image/jpeg)
2003-02-14 09:54 UTC, Leonid Kanter
no flags Details

Description Tim Waugh 2003-02-09 20:23:09 UTC
Description of problem:
The message headers are all invisible.

Version-Release number of selected component (if applicable):
1.2.2-1

How reproducible:
100%

Steps to Reproduce:
1. Read a message.
    
Additional info:
Worked in 1.2.1-x.

Comment 1 Jeremy Katz 2003-02-10 00:58:40 UTC
Downgrade to gtkhtml 1.1.8-1 and everything is fine.  I've marked 1.1.8-2 as
failed in the build system for now since it seems to be it which is breaking things.

Comment 2 Jeremy Katz 2003-02-10 03:17:41 UTC
*** Bug 83918 has been marked as a duplicate of this bug. ***

Comment 3 Peter Bowen 2003-02-10 04:17:16 UTC
I rebuilt gtkhtml-1.1.8-2 without the gtkhtml-1.1.7-fixfont.patch enabled.  This
fixed all the font problems I have seen.

Comment 4 Akira TAGOH 2003-02-10 07:16:07 UTC
Probably it's fontset issue... so if you change the font to the appropriate font
on the font configuration, this problem is fixed, right?
I'll make 1.1.8-3 without fontset as default font.

Comment 5 Akira TAGOH 2003-02-10 09:36:04 UTC
should be fixed in 1.1.8-3. Please verify it.

Comment 6 Tim Waugh 2003-02-10 09:47:39 UTC
Works for me.  Thanks.

Comment 7 Leonid Kanter 2003-02-11 16:52:37 UTC
gtkhtml uses incorrect default fontset not only for CJK, but for other locales
too . It can be discovered in following way:

1. find this line in gtkhtml-properties.c: 
/* printf ("default encoding %s-%s\n%s\n%s\n", enc1, enc2, *var_name, *fix_name); */

and uncomment it. 
2. rebuild and install the library.
3. run gtkhtml-properties-capplet in ru_RU.KOI8-R locale from xterm

You'll see that encoding is ISO8859-1 while it must be ISO10646-1 for ru_RU.UTF-8.

It was tested on 1.1.8-3. 

I added more printfs and found that wrong font name came directly from this line:

font_name = get_font_name (style->font);

I tried to disable this block of code (replaced "if (font_name)" with "if (0)"
and added lines to spec file to call iso10646-1 font from ru.po like it was done
from CJK, and gtkhtml start to work by default. But it's a hack.

patch and spec file will be attached


Comment 8 Leonid Kanter 2003-02-11 16:58:54 UTC
Sorry, step 3 must be 

3. run gtkhtml-properties-capplet in ru_RU.UTF-8 locale from xterm


Comment 9 Leonid Kanter 2003-02-11 17:02:33 UTC
Created attachment 89998 [details]
This patch disable broken code

Comment 10 Leonid Kanter 2003-02-11 17:08:01 UTC
Created attachment 90002 [details]
This patch for spec file fixes Russian and Ukrainian

Comment 11 Leonid Kanter 2003-02-11 17:14:23 UTC
There are also many other locales that should be fixed in the same way. Better
fix the root cause (broken function) than patch .po file for every affected locale.

Comment 12 Akira TAGOH 2003-02-13 19:34:54 UTC
Hmm, could your evolution show the translated menu on UTF-8 locale? ru.po for
gtkhtml and evolution was encoded KOI8-R. even if gtkhtml can handles iso10646-1
encoding properly, I think you will see another problem.
On ru_RU.UTF-8 locale, no showing the translated menu on evolution is only me?



Comment 13 Leonid Kanter 2003-02-13 20:01:50 UTC
Both gtkhtml and evolution translations already were in UTF-8 in evolution-1.0.8
and everything were OK, but these new translations were not commited to 1.2
branch. I updated russian translation for evolution-1.2.x and gtkhtml and they
were commited to gnome cvs by gnome-russian coordinator few days ago (I have no
acces for gnome cvs). I recompiled gtkhtml and evolution-1.2.2 with new utf
translations and verified that it's OK. If you can pick it up from there it
would be great.


Comment 14 Leonid Kanter 2003-02-14 09:54:08 UTC
Created attachment 90082 [details]
Underlines under icons are result of KOI8-R translation.

UTF-8 translation from cvs fix this problem

Comment 15 Akira TAGOH 2003-07-10 07:37:10 UTC

*** This bug has been marked as a duplicate of 84593 ***

Comment 16 Red Hat Bugzilla 2006-02-21 18:51:40 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.