Bug 83900 - XFree86 fails on Weitek P9100
XFree86 fails on Weitek P9100
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
All Linux
low Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-09 15:30 EST by Alan Cox
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-20 11:01:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2003-02-09 15:30:02 EST
Description of problem:

I'm sure it was working in 4.2 as unaccelerated but maybe I still had the old
server.
Vesa is also failing so the best I can get is 320x200.  This is mostly a tag
item so that
we know its broken. I don't expect an instant fix

The installer runs XFree86 with the vga driver then the veaa driver the goes
back to text mode. That is all handled ok so you get a text mode box fine
Comment 1 Mike A. Harris 2003-02-10 11:43:45 EST
Please attach full X server log and config file.
Comment 2 Alan Cox 2003-02-10 14:52:46 EST
What do you want logs of . vesa can't find any matcing modes at all, vga gives
me 320x200 as 
it doesnt seem to know the chipset

Comment 3 Mike A. Harris 2003-02-11 03:56:20 EST
I thought the logs might show something useful..  I just checked the
XFree86 support site, and this hardware is completely unsupported in
4.2.1, and still not ported to 4.3.0.

http://www.xfree86.org/4.2.1/Status36.html#36

Does this card have a VESA VBE BIOS?  If so, what version of VBE?
I'm going to checkout the 3.3.6 codebase out of CVS and see how much
work might be involved in writing a Weitek driver for 9x00.
Comment 4 Alan Cox 2003-02-11 06:51:01 EST
Its a fairly old card. I dont know what VBE it has.

Before you worry about writing a driver I'd count the number of Weitek P9xxx
entries in our RHN stats. It might not be worth it.
Comment 5 Mike A. Harris 2003-02-11 07:31:49 EST
To get more than 2320x240 with "vga" you'd need to use color depth 4 with
the vga driver.  That will probably suck, but should give 640x480 16 colors.

Do you have docs for Weitek hardware by chance?  Might not be necessary,
because there is driver source in 3.3.6 I found.  A basic driver without
DGA/DPMS and all that crap might not be too difficult.
Comment 6 Mike A. Harris 2003-02-14 01:34:04 EST
Defering for future..  we can chat about working on a driver
for this if you like when time isn't so busy in the future.
I investigated 3.3.6 sources, and there should IMHO be enough
info there to get a driver going without accel, and probably
even with accel.

Note You need to log in before you can comment on or make changes to this bug.