This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 839003 - [jbossas] /usr/share/jbossas directory should be removed when uninstalling jbossas
[jbossas] /usr/share/jbossas directory should be removed when uninstalling jb...
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: jbossas (Show other bugs)
6.1.0
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Fernando Nasser
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 11:34 EDT by Kiril Nesenko
Modified: 2014-07-10 20:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 12:31:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tree (41.52 KB, text/plain)
2012-07-10 11:34 EDT, Kiril Nesenko
no flags Details

  None (edit)
Description Kiril Nesenko 2012-07-10 11:34:21 EDT
Created attachment 597378 [details]
tree

Description of problem:
/usr/share/jbossas directory should be removed when uninstalling jbossas
I have an older version and i am running:

yum remove `rpm -qa | grep ep6`
yum remove `rpm -qa | grep jboss`

When installing a new jbossas , it fails to start a service due to these dirs exist.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Remove jbossas - 
yum remove `rpm -qa | grep ep6`
yum remove `rpm -qa | grep jboss`

2. Check if /usr/share/jbossas exist.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Fernando Nasser 2013-02-26 12:31:33 EST
The JBoss AS creates files (and directories) under $JBOSS_HOME and thus the RPM system will not remove this directory or any user/system created files in it.  

The AS7 is designed so it can be updated and start with the previous config files in place, so unless you had an older AS in place like AS5 from EAP 5 (which may be your case) the files should not prevent the server to start.  Maybe you need to investigate the reason why the server is not starting if you want to pursue this method.

If you are upgrading from EAP 5 you should add the 
rm -fr /usr/share/jbossas/ 
after your two commands above.

If you are upgrading from EAP 6 then you need to follow the instruction on how to upgrade from the previous EAP 6 release from the Guide.

I hope that helps.

Note You need to log in before you can comment on or make changes to this bug.