Bug 839031 - openssl s_server doesn't work on IPv4-only systems
Summary: openssl s_server doesn't work on IPv4-only systems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openssl
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-10 18:09 UTC by Miloslav Trmač
Modified: 2012-07-21 02:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-21 02:50:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Miloslav Trmač 2012-07-10 18:09:23 UTC
Version-Release number of selected component (if applicable):
openssl-1.0.0j-1.fc17.x86_64
glibc-2.15-37.fc17.x86_64


Steps to Reproduce:
1. Check that (ip addr ls|grep inet6.*global) doesn't return anything
2. $ openssl s_server -accept 64000
> Using default temp DH parameters
> ACCEPT
> getaddrinfo: Name or service not known
>   0 items in the session cache
<snip>
3. # ip addr add ::2/128 scope global dev lo
4. $ openssl s_server -accept 64000
   ...works
  
Additional info:
With AI_ADDRCONFIG and no global IPv6 address, getaddrinfo(NULL, "64000", hints->ai_family==AF_INET6) does not resolve into an address (due to AI_ADDRCONFIG it only wants to return an IPv4 address); init_server() treats this as a fatal error and does not try IPv4 at all (nor does it manage to bind to ::1 in IPv6, which would accept both IPv4 and IPv6).

The loop in init_server() looks somewhat suspect, but that's just a vague notion, I _don't_ know for sure how this is supposed to be done correctly.  See #808147 for relevant discussion.

Comment 1 Fedora Update System 2012-07-12 10:13:08 UTC
openssl-1.0.0j-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openssl-1.0.0j-2.fc17

Comment 2 Fedora Update System 2012-07-12 19:00:53 UTC
Package openssl-1.0.0j-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openssl-1.0.0j-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10593/openssl-1.0.0j-2.fc17
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2012-07-21 02:50:34 UTC
openssl-1.0.0j-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.