Bug 839052 - [RFE] Include self.timeout from /usr/lib/yum-plugins/rhnplugin.py in /etc/yum.conf
[RFE] Include self.timeout from /usr/lib/yum-plugins/rhnplugin.py in /etc/yum...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
1.8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Herr
Red Hat Satellite QA List
: FutureFeature
Depends On: 783958
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-07-10 15:23 EDT by Stephen Herr
Modified: 2014-01-21 01:25 EST (History)
5 users (show)

See Also:
Fixed In Version: yum-rhn-plugin-1.8.3-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 783958
Environment:
Last Closed: 2012-11-01 12:22:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Herr 2012-07-10 15:23:23 EDT
+++ This bug was initially created as a clone of Bug #783958 +++

*** Description of problem:
Customer has to manually change (sed -i 's/self.timeout = 60.0/self.timeout = 300.0/' /usr/lib/yum-plugins/rhnplugin.py) the self.timeout in /usr/lib/yum-plugins/rhnplugin.py to have the yum working. He has slow connection over RHN proxy to the RHN and without this modification he got the following error when he executed "yum upgrade":

10:18:13.740928 write(2, "Error: failed to retrieve repodata/d916920b62d0e122ecfbf8d7bc80d6072a04d7eb-filelists.xml.gz from rhel-x86_64-server-5\nerror was [Errno 12] Timeout: <urlopen error >\n", 166) = 166 <0.000535>


*** Version-Release number of selected component (if applicable):
yum-3.2.22-37.el5.noarch

*** How reproducible:
See steps below.

*** Steps to Reproduce:
1. Install RHN proxy to the server with slow connection to RHN.
2. Configure RHEL5 server to download updates using the RHN proxy server.
3. Run "yum upgrade" or "yum makecache"
  
*** Actual results:

# yum.makecache

10:14:09.314109 write(1, "2011-12-22 10:14:09,313 attempt 1/1: https://server.example.com/XMLRPC/GET-REQ/rhel-x86_64-server-5/repodata/d916920b62d0e122ecfbf8d7bc80d6072a04d7eb-filelists.xml.gz\n", 170) = 170 <0.000209>
10:14:09.314737 write(2, "INFO:urlgrabber:attempt 1/1: https://server.example.com/XMLRPC/GET-REQ/rhel-x86_64-server-5/repodata/d916920b62d0e122ecfbf8d7bc80d6072a04d7eb-filelists.xml.gz\n", 162) = 162 <0.000176>
[...]
10:14:09.353586 read(7, "\260G\244-\336\36\32 \271`\17\273\270\205\227<\222\214\4L\343\275\251\241\26\v/\204\243A\226\277\344\24\17Xy \312\274\343\225K\316,\207\204\371", 48) = 48 <0.000018>
10:14:09.354073 gettimeofday({1324545249, 354130}, NULL) = 0 <0.000015>
10:14:09.354352 write(7, "\27\3\1\1\[...]", 389) = 389 <0.000084>
10:14:09.355103 gettimeofday({1324545249, 355150}, NULL) = 0 <0.000013>
10:14:09.355214 read(7, 0x12f785d0, 5)  = -1 EAGAIN (Resource temporarily unavailable) <0.000018>
10:14:09.355320 gettimeofday({1324545249, 355351}, NULL) = 0 <0.000013>
10:14:09.355407 poll([{fd=7, events=POLLIN}], 1, 60000) = 0 (Timeout) <59.999445>
10:15:09.355444 write(7, "\25\3\1\0 \375\6\336\220\26\362\351\320\6~\256\274\3565-h\177\315!G\6\16od\267\224\304\220\25\r\2007", 37) = 37 <0.000328>
10:15:09.356311 close(7)                = 0 <0.000148>
10:15:09.356874 gettimeofday({1324545309, 356927}, NULL) = 0 <0.000015>
10:15:09.357297 stat("/etc/localtime", {st_dev=makedev(252, 0), st_ino=131140, st_mode=S_IFREG|0644, st_nlink=1, st_uid=0, st_gid=0, st_blksize=4096, st_blocks=16, st_size=2246, st_atime=2011/12/22-10:15:09, st_mtime=2010/05/17-10:45:27, st_ctime=2010/05/17-10:45:27}) = 0 <0.000018>
10:15:09.357521 write(1, "2011-12-22 10:15:09,356 exception: [Errno 12] Timeout: <urlopen error >\n", 72) = 72 <0.000399>
10:15:09.358191 write(2, "INFO:urlgrabber:exception: [Errno 12] Timeout: <urlopen error >\n", 64) = 64 <0.000309>

We tried modifying the yum.conf timeout setting, without success, so apparently self.timeout takes precedence over the yum.conf setting.


*** Expected results:
"yum upgrade" or "yum.makecache" will finish without errors


*** Additional info:
Please consider creating "self.timeout" setting in /etc/yum.conf, because it's much easier than modify it in /usr/lib/yum-plugins/rhnplugin.py which is replaced after every yum upgrade process.
Comment 1 Stephen Herr 2012-07-10 15:26:41 EDT
Committed to Spacewalk master: c512bfb3804a2465d2533689fa6d8aac23487fa4
Comment 2 Jan Pazdziora 2012-10-30 15:27:16 EDT
Moving ON_QA. Packages that address this bugzilla should now be available in yum repos at http://yum.spacewalkproject.org/nightly/
Comment 3 Jan Pazdziora 2012-11-01 12:22:10 EDT
Spacewalk 1.8 has been released: https://fedorahosted.org/spacewalk/wiki/ReleaseNotes18

Note You need to log in before you can comment on or make changes to this bug.