Bug 839065 - Dcitionary allways set back to wrong locale
Dcitionary allways set back to wrong locale
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 15:58 EDT by Heiko Adams
Modified: 2012-07-11 15:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 15:18:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2012-07-10 15:58:48 EDT
Description of problem:
Since updating firefox to v13 the dictionary is allways set to a wrong one (like "English / Namibia" or "German / Austria"). general.useragent.locale in about:config is set to "de" and locale says:
$ locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

Switching to the correct "Deutsch / Deutschland" dictionary seems to be unsaved.

Version-Release number of selected component (if applicable):
firefox-13.0.1-1.fc17.x86_64
xulrunner-13.0.1-1.fc17.x86_64

How reproducible:
allways

Steps to Reproduce:
1. Start firefox and navigate i.e. to pastebin.com
2. Change dictionary
3. Restart firefox and navigate i.e. to pastebin.com again
  
Actual results:
Changing dictionary seems to be rolled back

Expected results:
The changed dictionary should still be active

Additional info:
A german dictinoary is installed
Comment 1 Heiko Adams 2012-07-11 15:18:30 EDT
Not a firefox bug. An extension I played around some weeks ago has modified my proxy-settings. After setting them back to default everything works fine again.

Note You need to log in before you can comment on or make changes to this bug.