Bug 839093 - Can't reimport System.csv list after downloading
Can't reimport System.csv list after downloading
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.9.2
: ---
Assigned To: Steven Lawrance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 18:35 EDT by andrew
Modified: 2012-08-09 04:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 04:07:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andrew 2012-07-10 18:35:32 EDT
Description of problem:
Can't reimport System.csv list after downloading.

Version-Release number of selected component (if applicable):


How reproducible:100%


Steps to Reproduce:
1.Click Admin-> Export -> Systems -> Export csv
2.head -n 2 system.csv > test.csv then import
3.
  
Actual results: systemname: Invalid secret None


Expected results: no error 


Additional info:
Comment 1 Dan Callaghan 2012-08-05 23:55:19 EDT
For future reference, the bug here was that False values were being incorrectly converted to empty string, and so the importer was barfing because the 'secret' column had '' instead of 'False'.
Comment 2 Dan Callaghan 2012-08-09 04:07:00 EDT
Beaker 0.9.2 has been released.

Note You need to log in before you can comment on or make changes to this bug.