Bug 839126 - rpm(8) manual page missing information about --setperms and --setugid
rpm(8) manual page missing information about --setperms and --setugid
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rpm (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Panu Matilainen
Patrik Kis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 00:03 EDT by Murray McAllister
Modified: 2015-01-04 17:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:51:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0461 normal SHIPPED_LIVE rpm bug fix and enhancement update 2013-02-20 16:07:23 EST

  None (edit)
Description Murray McAllister 2012-07-11 00:03:18 EDT
Description of problem:
The rpm(8) manual page mentions:

rpm {--setperms|--setugids} PACKAGE_NAME ...

--setperms sounds very useful, but there is no description of what it does or why you would use it in the manual page. Can that information please be added?

Version-Release number of selected component (if applicable):
rpm-4.8.0-27.el6.x86_64
Comment 1 Kurt Seifried 2012-07-11 00:07:43 EDT
Also --setugids is missing any information.
Comment 3 Florian Festi 2012-07-31 10:42:30 EDT
It probably worth checking the whole man page for missing parameters and then decide whether to add them all or to point to some external documentation.
Comment 4 RHEL Product and Program Management 2012-08-14 17:59:48 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 10 errata-xmlrpc 2013-02-21 05:51:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0461.html

Note You need to log in before you can comment on or make changes to this bug.