Bug 839204 - NSS support of aes-gcm implementation for Openswan
NSS support of aes-gcm implementation for Openswan
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nss (Show other bugs)
7.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Elio Maldonado Batiz
Hubert Kario
:
Depends On:
Blocks: 717789 1057566 826264
  Show dependency treegraph
 
Reported: 2012-07-11 04:23 EDT by Eduard Benes
Modified: 2014-06-13 09:11 EDT (History)
7 users (show)

See Also:
Fixed In Version: nss-3.15-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 826264
Environment:
Last Closed: 2014-06-13 09:11:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 373108 None None None 2012-07-11 04:23:12 EDT

  None (edit)
Description Eduard Benes 2012-07-11 04:23:11 EDT
+++ This bug was initially created as a clone of Bug #826264 +++

Description of problem:
Current openswan codes does not have support for aes-gcm algorithms.

--- Additional comment from avagarwa@redhat.com on 2012-05-29 17:37:46 EDT ---

Since Openswan uses NSS crypto library for cryptograhic operation with IKE, NSS should must support aes-gcm too. I have created upstream bug for this:

https://bugzilla.mozilla.org/show_bug.cgi?id=755500 

The attached patch only solves the issues with ESP as kernel has support for aes-gcm.
Comment 2 Avesh Agarwal 2012-11-12 12:57:17 EST
sorry, by mistake updated the wrong bug, i was supposed to update 826264.
Comment 4 Elio Maldonado Batiz 2013-02-15 13:29:49 EST
Support for AES Galois Counter Mode was added upstream in nss-3.14. See 
https://bugzilla.mozilla.org/show_bug.cgi?id=373108 which is now in FIXED status.
Comment 6 Ludek Smid 2014-06-13 09:11:58 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.