Bug 839209 - Can't import template(s) more than once
Can't import template(s) more than once
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity high
: ---
: 3.1.0
Assigned To: Gilad Chaplik
vvyazmin@redhat.com
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 04:38 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 11:35 EST (History)
9 users (show)

See Also:
Fixed In Version: si11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-24 12:39:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vvyazmin@redhat.com 2012-07-11 04:38:49 EDT
Description of problem:
Can't import template(s) more than once 

Version-Release number of selected component (if applicable):
RHEV-M: rhevm-3.1.0-5.el6ev.noarch
VDSM: vdsm-4.9.6-17.0.el6.x86_64
LIBVIRT: libvirt-0.9.10-21.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64

How reproducible:
Import template(s) from NFS Export Domain

Steps to Reproduce:
1. Create a VM
2. Create a Template(s) from VM (that created in privies step)
3. Export Template(s) to NFS Export Domain (that created in privies step)
4. Import Template(s) from NFS Export Domain
  • Check box "Clone All Templates" - marks 
  • Suffix: _Copy

Actual results:
Button "OK" not working, because I get a warning:
  "New name (with suffix) cannot contains blanks or special characters. Maximum length: 40"

Expected results:
Succeed import template(s) from Storage Domain with suffix, more than once.

Workaround: 
Delete Template(s) from Storage Domain a template(s), and than you can import Template(s) from NFS Export Domain
Comment 1 Haim 2012-07-11 07:11:03 EDT
Gilad - did you implement the import template more then once ? if so, is it in si9.1 ?
Comment 2 Gilad Chaplik 2012-07-11 07:26:29 EDT
it is, but this is a new bug.
Comment 4 vvyazmin@redhat.com 2012-07-24 08:15:35 EDT
Verified on RHEVM 3.1 - SI11

RHEVM: rhevm-3.1.0-7.el6ev.noarch.rpm
VDSM: vdsm-4.9.6-23.0.el6.x86_64
LIBVIRT: libvirt-0.9.10-21.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64
SANLOCK: sanlock-2.3-2.1.el6.x86_64

Note You need to log in before you can comment on or make changes to this bug.