Bug 839223 - c++ client throws exception when connections are stored in global namespace
c++ client throws exception when connections are stored in global namespace
Status: CLOSED DUPLICATE of bug 567617
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
2.1
Unspecified Linux
low Severity low
: ---
: ---
Assigned To: Andrew Stitcher
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 05:32 EDT by Zdenek Kraus
Modified: 2013-05-02 16:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-02 16:35:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer -- simple connector client (3.90 KB, text/plain)
2012-07-11 05:33 EDT, Zdenek Kraus
no flags Details

  None (edit)
Description Zdenek Kraus 2012-07-11 05:32:29 EDT
Description of problem:
When client code stores connections in global namespace, then when program ends qpid::Exception is thrown in internal thread and aborts program. When the same code has connections stored in local namespace, exception will not occure.

Version-Release number of selected component (if applicable):
qpid-cpp-client-devel-0.14-18.el5.i386
qpid-cpp-client-devel-0.14-18.el5.x86_64
qpid-cpp-client-devel-0.14-14.el5.i386
qpid-cpp-client-devel-0.14-14.el5.x86_64
qpid-cpp-client-devel-0.14-14.el6.i386
qpid-cpp-client-devel-0.14-14.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. compile reproducer, example: g++ -g -O2 -lqpidmessaging connector.cc -o connector
2. start broker without authentication
3. launch attached reproducer, exmaple: "./connector localhost:5672 1"

  
Actual results:
Opened connections: 1
terminate called after throwing an instance of 'qpid::Exception'
  what():  Invalid argument (../include/qpid/sys/posix/Mutex.h:116)
Aborted (core dumped)


Expected results:
Opened connections: 1

Additional info:
Comment 1 Zdenek Kraus 2012-07-11 05:33:30 EDT
Created attachment 597517 [details]
reproducer -- simple connector client
Comment 2 Andrew Stitcher 2013-05-02 16:35:04 EDT
This is a duplicate of an old bug (Bug 567617)

*** This bug has been marked as a duplicate of bug 567617 ***

Note You need to log in before you can comment on or make changes to this bug.