Bug 839237 - please update Armadillo package to latest upstream version
please update Armadillo package to latest upstream version
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: armadillo (Show other bugs)
17
All Linux
medium Severity medium
: ---
: ---
Assigned To: José Matos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 06:21 EDT by C Sand
Modified: 2012-08-09 18:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 18:57:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updated f17 armadillo srpm (2.79 MB, application/x-rpm)
2012-07-18 18:21 EDT, Ryan Curtin
no flags Details

  None (edit)
Description C Sand 2012-07-11 06:21:52 EDT
Description of problem:

Armadillo version 2.2.3 is outdated in Fedora. This version is no longer supported upstream.

Please update the Armadillo package to latest upstream version. The latest version is considerably faster and has more functionality than what is present in Fedora.

New upstream version available at:
http://sourceforge.net/projects/arma/files/

Armadillo project home, showing changelog:
http://arma.sourceforge.net
Comment 1 Ryan Curtin 2012-07-18 18:21:52 EDT
Created attachment 599012 [details]
updated f17 armadillo srpm

I have built Armadillo 3.0.4 using koji (http://koji.fedoraproject.org/koji/taskinfo?taskID=4253011 -- I don't know how long that link is valid for) and attached the SRPM.

I used 3.0.4 because the 3.2.x releases are affected by #831550, so until the patches applied to fix http://gcc.gnu.org/bugzilla/show_bug.cgi?id=53549 find their way into Fedora it doesn't make sense to upgrade to a version which will have problems.
Comment 2 José Matos 2012-07-26 05:31:11 EDT
I have updated the version in devel (rawhide) since I expect gcc 4.7.2 to be release before F18 release (certainly).

My problem with updating for f17 and f16 is that all the code compiled with versions available in those versions will not run with the new version.

OTOH the previous version is no longer supported upstream.

Due to the changes involved I am pending to update it at least for F17. The package as it is compiles cleanly there. Actually I have done so

http://koji.fedoraproject.org/koji/taskinfo?taskID=4330568

For F16 I am more reluctant.

What do you think?
Comment 3 C Sand 2012-07-26 21:17:36 EDT
The update for F17 it should be fine.  Armadillo 3.2.4 contains a workaround for the GCC 4.7.0 and 4.7.1 bug, meaning it will compile on F17.

The changes in the API between Armadillo 2.x and 3.x were carefully done to minimise
breaking user code, with work-arounds added to catch several corner sitations. In other words, "run of the mill" user code that doesn't delve into private Armadillo internals, and simply uses -larmadillo for linking, should compile fine with 3.x. Where it doesn't, only minor changes are necessary.

Upstream is no longer maintaining 2.x, and 3.x corrects several bugs that are present in 2.x.  As such, moving to 3.x is recommended anyway.
Comment 4 Fedora Update System 2012-07-27 05:20:11 EDT
armadillo-3.2.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/armadillo-3.2.4-1.fc17
Comment 5 Fedora Update System 2012-07-27 21:23:05 EDT
Package armadillo-3.2.4-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing armadillo-3.2.4-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11212/armadillo-3.2.4-1.fc17
then log in and leave karma (feedback).
Comment 6 C Sand 2012-07-30 01:44:36 EDT
Thanks. Update works for me on a stock F17 install.
Comment 7 Fedora Update System 2012-08-09 18:57:17 EDT
armadillo-3.2.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.