Bug 839316 - webadmin [GUIDE ME]: we are missing the select host option from the guide me dialogue
webadmin [GUIDE ME]: we are missing the select host option from the guide me ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: ofri
Tomas Dosek
infra
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 10:49 EDT by Dafna Ron
Modified: 2016-02-10 14:17 EST (History)
10 users (show)

See Also:
Fixed In Version: si14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:01:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shots (45.78 KB, application/x-gzip)
2012-07-11 10:49 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-07-11 10:49:46 EDT
Created attachment 597597 [details]
screen shots

Description of problem:

in 3.0 we had an option 'select host' which allowed us to select an existing host in maintenance state through the create new DC-> cluster dialogues. 
in 3.1 this option does not exist.

Version-Release number of selected component (if applicable):

si9.1

How reproducible:

100%

Steps to Reproduce:
1. put a host in maintenance 
2. create a new DC
3. through the guide me -> create a new cluster -> no option for selecting host
  
Actual results:

this used to exist in 3.0 but does not exist in 3.1

Expected results:

option should exist in 3.1

Additional info: screen shot
Comment 2 ofri 2012-07-29 11:39:13 EDT
Could not reproduce. It seems like an issue of misfit between the oVirt and VDSM versions. Please supply a reproducable.
Comment 3 Haim 2012-07-30 04:01:09 EDT
(In reply to comment #2)
> Could not reproduce. It seems like an issue of misfit between the oVirt and
> VDSM versions. Please supply a reproducable.

its indeed reproduce on our official version SI12 - please use correct source code (i.e downstream git).
Comment 4 ofri 2012-07-31 03:13:56 EDT
The UI was modified to match older UI versions - so the button would always
appear. Nevertheless, if the host version is not compatible with the 
cluster version (or no host in maintenance mode) the button would be disabled.
Comment 5 Einav Cohen 2012-08-02 07:28:23 EDT
note that you should probably look on the VDS's "supportedRHEVMs" (instead of on "software_version") - so the comparison will be more trivial/correct.
Comment 8 Tomas Dosek 2012-08-09 03:54:48 EDT
Note - required version of vdsm for host (3.1 version) is vdsm-4.10.x. This patch cannot be tested for 3.1 DC/Cluster unless vdsm team releases this new version (in acked form).
Comment 10 Tomas Dosek 2012-08-20 07:11:35 EDT
Verified - si14 - While creating Datacenter user's now able to select host which is in maintenance state and use it in the new dc as a part fo Guide me dialogue.

Note You need to log in before you can comment on or make changes to this bug.