Bug 839323 - imagefactory needs to be sure kvm modules & services are in place
imagefactory needs to be sure kvm modules & services are in place
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: imagefactory (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Ian McLeod
Giulio Fidente
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 11:05 EDT by Dave Johnson
Modified: 2012-12-04 10:12 EST (History)
6 users (show)

See Also:
Fixed In Version: imagefactory-1.0.2-1.el6cf
Doc Type: Release Note
Doc Text:
When running CloudForms Cloud Engine 1.0.1 using libvirt-0.9.10-21.el6_3.4, the KVM kernel modules were not automatically loaded by the libvirtd daemon. If the KVM modules were not loaded, attempts to build images to a RHEV or vSphere provider were failing. To workaround this issue, administrators must manually load the appropriate kernel modules. The following command will successfully load the appropriate KVM kernel modules. # sh /etc/sysconfig/modules/kvm.modules A future update of the RHEL libvirt package will resolve this issue (BZ#836498). Additionally, CloudForms 1.1 will also resolve this issue during Cloud Engine initial configuration.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:12:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2012-07-11 11:05:01 EDT
Description of problem:
====================================

So bug 829567, no kvm modules are loaded by default, is being bounced around between the teams to determine what the issue is.  A new comment was added pointing at qemu-kvm so I pushed the bug into their component for qualification.

In the mean time it appears imagefactory needs to be ready to deal with this especially if we are desiring to support RHEL 6.3 as a host in CF v1.0.2.

So, imagefactory needs to check that its requirements of kvm modules and perhaps libvirtd is started.
Comment 2 Mike Orazi 2012-08-06 18:24:33 EDT
Moving it back this should have already had devel-ack
Comment 3 Steve Linabery 2012-08-23 16:58:26 EDT
imagefactory-1.0.0rc11-1v11candidate3.el6cf
Comment 5 Giulio Fidente 2012-09-18 09:00:17 EDT
imagefactory-1.0.2-1.el6cf does not seem to fix this
Comment 6 Giulio Fidente 2012-09-18 11:29:25 EDT
imagefactory-1.0.2-1.el6cf does load 'kvm' and 'kvm_{intel,amd}' modules but does not start libvirtd; marking this bug as verified and opening a new bug 858295 for libvirtd
Comment 9 errata-xmlrpc 2012-12-04 10:12:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.