Bug 839325 - Exceptions from the client shouldn't be showed to the user
Exceptions from the client shouldn't be showed to the user
Status: CLOSED DUPLICATE of bug 836882
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: N. Harrison Ripps
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 11:10 EDT by Dan McPherson
Modified: 2015-05-14 22:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 16:21:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan McPherson 2012-07-11 11:10:11 EDT
Description of problem:

I am sure you can do this a number of ways.  In my case I tried to create two scalable apps.  Which resulted in an exception from the server.  And I see this on the client:

[dmcphers@mcpherson os-client-tools]$ rhc app create -l danmcp706 -a danmcp706a -t jbossas-7 -s -r /tmp/rhc/danmcp706a
Password: 

Creating application: danmcp706a in danmcp706
/usr/local/share/gems/gems/rhc-0.95.11/lib/rhc-rest.rb:132:in `block in process_error_response': Failed to create application danmcp706a due to: Unable to create gear on node (Rhc::Rest::ServerErrorException)
	from /usr/local/share/gems/gems/rhc-0.95.11/lib/rhc-rest.rb:130:in `each'
	from /usr/local/share/gems/gems/rhc-0.95.11/lib/rhc-rest.rb:130:in `process_error_response'
	from /usr/local/share/gems/gems/rhc-0.95.11/lib/rhc-rest.rb:76:in `rescue in send'
	from /usr/local/share/gems/gems/rhc-0.95.11/lib/rhc-rest.rb:64:in `send'
	from /usr/local/share/gems/gems/rhc-0.95.11/lib/rhc-rest/domain.rb:30:in `add_application'
	from /usr/local/share/gems/gems/rhc-0.95.11/lib/rhc-common.rb:512:in `create_app'
	from /usr/local/share/gems/gems/rhc-0.95.11/bin/rhc-app:230:in `create_app'
	from /usr/local/share/gems/gems/rhc-0.95.11/bin/rhc-app:505:in `<top (required)>'
	from /usr/local/bin/rhc-app:23:in `load'
	from /usr/local/bin/rhc-app:23:in `<main>'


We shouldn't be returning a stack trace from the client to the user here.  It implies the client is broken and can't handle errors.




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create two scalable apps
2.
3.
  
Actual results:
Get a stack trace

Expected results:
Should get a nicer error message


Additional info:
Comment 1 Clayton Coleman 2012-07-11 14:07:51 EDT
I think this is fixed by Harrison's issue.  Harrison, please investigate.
Comment 2 N. Harrison Ripps 2012-07-11 16:21:24 EDT
This class of error is covered by the fix to BZ836882

*** This bug has been marked as a duplicate of bug 836882 ***

Note You need to log in before you can comment on or make changes to this bug.