Bug 839332 - refactor the AS7 connection code out of the AS7 plugin into a common module for reuse
refactor the AS7 connection code out of the AS7 plugin into a common module f...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: RHQ 4.5.0
Assigned To: John Mazzitelli
Mike Foley
:
Depends On:
Blocks: 851268
  Show dependency treegraph
 
Reported: 2012-07-11 11:29 EDT by John Mazzitelli
Modified: 2012-09-25 10:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 11:40:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to refactor AS7 connection code to its own common client module (231.30 KB, patch)
2012-07-11 11:33 EDT, John Mazzitelli
no flags Details | Diff

  None (edit)
Description John Mazzitelli 2012-07-11 11:29:05 EDT
We should take the AS7 connection code and refactor it out of the AS7 plugin so we can reuse it elsewhere. I envision being able to use this in the RHQ Server (particularly the new installer, and maybe in the core server itself) so it can probe in the AS7 container it is running on and do things like deploy datasources, find out the version of the container, deploy the ear, undeploy the installer, etc etc. (things our current installer does).
Comment 1 John Mazzitelli 2012-07-11 11:33:36 EDT
Created attachment 597609 [details]
patch to refactor AS7 connection code to its own common client module
Comment 2 John Mazzitelli 2012-07-11 15:32:21 EDT
from ccrouch:

(12:15:33 PM) ccrouch: (10:35:00 AM) mazz: I attached my patch to refactor the AS7 connection code to its own common module
(12:15:34 PM) ccrouch: one thing to think about before merging this to master
(12:15:34 PM) ccrouch: is whether any of this code needs to get cherry picked for jon311
Comment 3 John Mazzitelli 2012-08-23 11:40:51 EDT
turns out, the RHQ Server won't be using the same client code as that of the AS7 plugin. so we can close this
Comment 4 John Mazzitelli 2012-09-25 10:00:06 EDT
NOTE: we now have our own common AS7 client, not based on the AS7 plugin, here:

modules/common/jboss-as-dmr-client

Note You need to log in before you can comment on or make changes to this bug.