Bug 839371 - Properties dialog hangs with TIFF images
Properties dialog hangs with TIFF images
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdk-pixbuf2 (Show other bugs)
17
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 14:24 EDT by Gareth Jones
Modified: 2013-02-08 18:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-08 18:41:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack trace of hung Nautilus from GDB (6.08 KB, application/octet-stream)
2012-07-13 07:03 EDT, Gareth Jones
no flags Details

  None (edit)
Description Gareth Jones 2012-07-11 14:24:17 EDT
Description of problem:
The Nautilus file properties dialog appears for TIFF images, but then freezes, along with all open Nautilus windows.  There are no messages reported to stdout or stderr.  It only hangs with "large" files (a 640x480 photo is enough to hang it), but it works okay with icon-sized TIFFs.

Version-Release number of selected component (if applicable):
3.4.2-5.fc17

How reproducible:
Every time.

Steps to Reproduce:
1. Save a photo as a TIFF, e.g. with GIMP.  Options don't seem to matter.
2. Right-click on the TIFF image file in Nautilus.
3. Click Properties.
  
Actual results:
The properties window shows, but it and all other Nautilus windows are unresponsive to further input.  There is no unusual CPU or memory usage from the Nautilus process.

Expected results:
A normal functional image properties window.

Additional info:
This is an x86-64 machine.  I haven't tested x86-32.
Comment 1 Gareth Jones 2012-07-11 16:46:46 EDT
I forgot to mention that there is nothing relating to the error in .xsession-errors either.
Comment 2 Tomáš Bžatek 2012-07-12 05:13:32 EDT
Thank you for the report, please grab a backtrace of the frozen process that would help us to reveal the true issue.

https://fedoraproject.org/wiki/StackTraces
Comment 3 Gareth Jones 2012-07-13 07:03:36 EDT
Created attachment 598041 [details]
Stack trace of hung Nautilus from GDB

Nautilus doesn't actually crash, so abrt doesn't appear.  I used GDB and Ctrl-c when Nautilus stopped responding, and "thread apply all bt full" to generate the trace.
Comment 4 Tomáš Bžatek 2012-07-17 06:20:45 EDT
Thanks, this looks like a freeze in GdkPixbufLoader trying to load a symbolic SVG file. Reassigning to gdk-pixbuf2.
Comment 5 Colin Adams 2012-09-02 03:02:47 EDT
I have the same problem with .NEF files (Nikon RAW format), which are all huge (over 10MB).
Comment 6 Dino 2012-09-23 15:47:52 EDT
I have this problem under Ubuntu 12.04 (x64).  I found your bug report and wanted to add, in my case, at least, if I copy the tiff file from mu /Home/Picture forlder to the Desktop folder, I can view the properties. I haven't checked all the folders under Home but I believe Desktop is the only folder where a properties request does not hang Nautilus.
Comment 7 Gareth Jones 2013-02-07 11:41:55 EST
This appears to be fixed in Fedora 18.

Note You need to log in before you can comment on or make changes to this bug.