Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 83942 - galeon memory leak
Summary: galeon memory leak
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: galeon
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-10 12:38 UTC by Gene Czarcinski
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-10-27 19:25:14 UTC


Attachments (Terms of Use)

Description Gene Czarcinski 2003-02-10 12:38:24 UTC
Description of problem:
Galeon appears to have a memory leak.

I run three instances of galeon plus ofter have url references in new windows
(yet another instance).  As time elapses (two to three hours) and I do some web
browsing, memory usage (as reported by gnome-system-monitor) goes.  For example,
it is currently 43.1 MB Total and 18.2 MB Shared.  This generally starts as
about 20 to 25 MB Total.

I have tried to use memprof to debug this but because galeon does a fork, the
actual process doing the display is not followed.

Version-Release number of selected component (if applicable):
re0204 (galeon - 1.2.7-3 and mozilla - 1.2.1-19.

How reproducible:
yes

Comment 1 Kjartan Maraas 2003-02-17 22:49:39 UTC
Did you try to tell memprof to follow forks?

Comment 2 Gene Czarcinski 2003-10-27 19:25:14 UTC
OBE


Note You need to log in before you can comment on or make changes to this bug.