Bug 839500 - Should not generate the virtual "Available subscriptions" to Activation key.
Should not generate the virtual "Available subscriptions" to Activation key.
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity high
: beta
: 1.2
Assigned To: Tom McKay
SAM QE List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 02:51 EDT by Hui Wang
Modified: 2012-09-19 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 12:43:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
applied subscription of key1 (136.25 KB, image/png)
2012-07-12 02:51 EDT, Hui Wang
no flags Details
Available subscriptions of key2 (151.78 KB, image/png)
2012-07-12 02:54 EDT, Hui Wang
no flags Details
Current "Available subscriptions" of key2 (151.06 KB, image/png)
2012-07-12 02:55 EDT, Hui Wang
no flags Details

  None (edit)
Description Hui Wang 2012-07-12 02:51:55 EDT
Created attachment 597717 [details]
applied subscription of key1

Description of problem:

When client registering to SAM with Activation key that binded one product pool, it will generate one virtual product pool for other Activation keys.
It should be generated only when the client is Host and the virt-who is running. 
If the client is not host and the virt-who is stop, it should not generate the virt "Available subscriptions". 

Version-Release number of selected component (if applicable):
katello-certs-tools-1.1.5-1.el6_2.noarch
katello-configure-0.3.7-1.el6_2.noarch
katello-cli-headpin-0.2.2-1.el6_2.noarch
katello-common-0.3.3-1.el6_2.noarch
katello-cli-common-0.3.5-2.el6_2.noarch
katello-headpin-0.2.13-1.el6_2.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-selinux-0.2.4-1.el6_2.noarch
katello-headpin-all-0.2.13-1.el6_2.noarch
katello-glue-candlepin-0.3.3-1.el6_2.noarch
candlepin-tomcat6-0.6.5-1.el6_2.noarch
candlepin-0.6.5-1.el6_2.noarch


How reproducible:
100%

Steps to Reproduce:
1. Create an Activation key key1 that bind the product pool and create another Activation key key2. See the attachment1 [details]

2. List the "Available subscriptions" of key2, see the attachment2 [details]

2. Register client by key1

3. List the "Available subscriptions" of key2, see the attachment3 [details]
  
Actual results:
List the "Available subscriptions" of key2, we can see one product pool is virtual pool, and we can choose the pool add to key2.

Expected results:
Should not generate the virtual "Available subscriptions" to key2.

Additional info:
Comment 1 Hui Wang 2012-07-12 02:54:19 EDT
Created attachment 597718 [details]
Available subscriptions of key2
Comment 2 Hui Wang 2012-07-12 02:55:07 EDT
Created attachment 597719 [details]
Current "Available subscriptions" of key2
Comment 3 Hui Wang 2012-07-12 03:00:12 EDT
Sorry for the wrong link, pls see the attachments as following names:
attachment1 [details]: attachment 597717 [details]

attachment2 [details]: attachment 597718 [details] 
attachment3 [details]: attachment 597719 [details]
Comment 4 Tom McKay 2012-09-10 08:14:47 EDT
I believe this is working as intended. The generation of the virtual guest subscription is not based upon whether the consuming system of the original subscription is currently a host or no.

If you have questions surrounding this, please let me know otherwise I will close this ticket.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.