Bug 839560 - Removing system group along with systems which are associated with other system groups shouldn't be allowed
Removing system group along with systems which are associated with other syst...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Jason E. Rist
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 05:59 EDT by Sachin Ghai
Modified: 2013-08-16 14:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 11:31:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachin Ghai 2012-07-12 05:59:33 EDT
Description of problem:
Assuming that one system can belong to multiple system-groups. So while removing a system group with associated systems, and same system is associated with other system group, UI should raise a proper warning message.


Version-Release number of selected component (if applicable):
katello-0.2.44-1.git.73.3737e93.el6_3.noarch

How reproducible:
always

Steps to Reproduce:
1. Register 'systemA' 
2. Create a system group 'sysgrp1'
3. Add 'systemA' to sysgrp1.
4. Create another system group 'sysgrp2'
5. Add 'systemA' to 'sysgrp2'
6. Now remove sysgrp1 along with associated systemA
  
Actual results:
UI simply remove the system group and associated system.

Expected results:
UI should raise a warning message/validation error that the same system is associated with other system group

Additional info:
Comment 1 Mike McCune 2012-07-18 11:31:02 EDT
this is working as designed, mass-deletion already has a warning dialog and we should not block the deletion because the systems exist in another group.
Comment 2 Mike McCune 2013-08-16 14:21:40 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.