Bug 839564 - vdservice stops running inside windows guests - mouse pointer cannot click
vdservice stops running inside windows guests - mouse pointer cannot click
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-vdagent-win (Show other bugs)
3.0.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Arnon Gilboa
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 06:15 EDT by Grant Williamson
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version: vdagent-win-0.1-12
Doc Type: Bug Fix
Doc Text:
When running a Windows guest sometimes the vdservice stopped running,causing the mouse pointer to no longer click or accept input inside the guest. An update has been made to ensure that the vdagent starts correctly and these problems will no longer occur. As a result the guest's mouse will now respond correctly to user input.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 13:17:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdagent log (126.46 KB, text/x-log)
2012-07-12 06:15 EDT, Grant Williamson
no flags Details
vdservice log when it has crashed. (42.61 KB, text/x-log)
2012-07-12 06:15 EDT, Grant Williamson
no flags Details
Service not working direct after boot. (25.70 KB, text/x-log)
2012-09-04 06:33 EDT, Grant Williamson
no flags Details
Service not working on boot. (72.08 KB, text/x-log)
2012-09-04 06:34 EDT, Grant Williamson
no flags Details
vdservice: retry virtio-serial read on ERROR_NO_SYSTEM_RESOURCES (1450) (1018 bytes, patch)
2012-09-16 07:00 EDT, Arnon Gilboa
no flags Details | Diff
vdservice: stop service on virtio failure (7.25 KB, patch)
2012-09-16 07:01 EDT, Arnon Gilboa
no flags Details | Diff

  None (edit)
Description Grant Williamson 2012-07-12 06:15:23 EDT
Created attachment 597755 [details]
vdagent log

Description of problem:
When running a Windows guest sometimes the vdservice will stop running.
Causing mouse pointer to no longer click, accept input inside guest.

Version-Release number of selected component (if applicable):
RHEL 6.3
Windows 7 or Windows XP.
vdagent-win-0.1-11
spice-gtk-0.11-11
qemu-kvm-0.12.1.2-2.295

I include the log files of an instance when it has crashed.
Comment 1 Grant Williamson 2012-07-12 06:15:56 EDT
Created attachment 597756 [details]
vdservice log when it has crashed.
Comment 3 Arnon Gilboa 2012-08-08 06:55:25 EDT
(In reply to comment #1)
> Created attachment 597756 [details]
> vdservice log when it has crashed.

Do you always get the "OpenInputDesktop() failed: 624" on vdagent.log before vdservice stops working?

MSDN says:
624 (0x270) ERROR_DLL_INIT_FAILED_LOGOFF
{DLL Initialization Failed} The application failed to initialize because the window station is shutting down.

Is it relevant to your scenario?
Comment 4 Grant Williamson 2012-08-09 06:35:37 EDT
Not sure, we worked around the problem by adding a auto restart on service fail.
I know from other people the problem also exists on Windows clients run on Fedora 17.
Comment 5 Arnon Gilboa 2012-08-13 08:45:06 EDT
(In reply to comment #4)
> Not sure, we worked around the problem by adding a auto restart on service
> fail.
Workaround is not a solution. Can you easily reproduce it? what's the exact scenario?

> I know from other people the problem also exists on Windows clients run on
> Fedora 17.
I guess you meant Windows guest?
Comment 6 Grant Williamson 2012-08-27 08:02:45 EDT
Windows Guest, yes. Windows XP 32 Bit or Windows 7 64 bit.
Install the service and at certain times, it just fails.

We have 1000's of people using the copy and paste feature of a Windows guest so a workaround was required.
Comment 7 Grant Williamson 2012-09-04 06:33:20 EDT
Created attachment 609620 [details]
Service not working direct after boot.
Comment 8 Grant Williamson 2012-09-04 06:34:10 EDT
Created attachment 609621 [details]
Service not working on boot.
Comment 9 Grant Williamson 2012-09-04 06:34:57 EDT
I disabled the auto restart, rebooted the KVM 2x and here you can see the service has crashed again.
I would say it is easy to reproduce.
Comment 10 Arnon Gilboa 2012-09-10 03:40:59 EDT
(In reply to comment #9)
> I disabled the auto restart, rebooted the KVM 2x and here you can see the
> service has crashed again.
> I would say it is easy to reproduce.

I cannot see the vdservice crash reason from logs. It seems like you don't get the OpenInputDesktop agent error, but there is a suspicious GetOverlappedResult failure (1450 = ERROR_NO_SYSTEM_RESOURCES) in vdservice, which doesn't stop the service but may give us a clue.

Which version of virtio serial drivers are you using?
Comment 11 Grant Williamson 2012-09-10 03:57:24 EDT
Arnon, we are using this driver.

virtio-serial(vioser.inf)	07/03/2012,52.63.103.3000
Comment 12 Arnon Gilboa 2012-09-11 03:55:06 EDT
Grant, it will be nice if we can debug it online as I cannot repro on my env.
Catch me at irc.gimp.net #spice

(In reply to comment #11)
> Arnon, we are using this driver.
> 
> virtio-serial(vioser.inf)	07/03/2012,52.63.103.3000
Comment 13 Grant Williamson 2012-09-12 02:36:32 EDT
Arnon, will try and ping you today.

Indeed seems error 1450 does occur quite often. Sometimes when you login the log shows Service stopped.
Comment 14 Grant Williamson 2012-09-12 11:32:41 EDT
Chatted with Arnon, outcome.

/* note: On WinXP SP3 with rhel6ga virtio-win-1.1.16 vioser drivers,
 * ENSR seems to be synonymous with when we'd normally expect
 * ERROR_HANDLE_EOF. So treat it as such. Microsoft's
 * recommendation for ERROR_NO_SYSTEM_RESOURCES is to
 * retry the read, so this happens to work out anyway. On newer
 * virtio-win driver, this seems to be replaced with EOA, so
 * handle that in the same fashion.
 */

1450 is  ERROR_NO_SYSTEM_RESOURCES

Testing updated vdservice.exe
Comment 15 Arnon Gilboa 2012-09-16 07:00:51 EDT
Created attachment 613394 [details]
vdservice: retry virtio-serial read on ERROR_NO_SYSTEM_RESOURCES (1450)
Comment 16 Arnon Gilboa 2012-09-16 07:01:31 EDT
Created attachment 613395 [details]
vdservice: stop service on virtio failure
Comment 17 Marian Krcmarik 2012-10-02 14:24:58 EDT
Grant,

We are not able to reproduce this bug for verification purposes, Could I kindly ask you for helping with verification? Would you be willing verify official build which I will provide to you before release?

Thank you in advance for response.

Marian Krcmarik
Comment 18 Grant Williamson 2012-10-03 05:56:14 EDT
I am running the 0.1-12 testing now.
Comment 23 errata-xmlrpc 2012-12-04 13:17:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1502.html

Note You need to log in before you can comment on or make changes to this bug.