Bug 839583 - utilisation graph is slow
utilisation graph is slow
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: Doc (Show other bugs)
0.9
Unspecified Unspecified
medium Severity medium (vote)
: 0.11
: ---
Assigned To: Dan Callaghan
Measurements
:
Depends On: 883606
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 07:25 EDT by Karel Srot
Modified: 2013-01-16 23:34 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-16 23:34:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Srot 2012-07-12 07:25:20 EDT
Description of problem:

Hi, 
utilisation graph has default date range 2009-05-21 - today.. maybe that is the reason why it takes so much time to load. I think most of the people are interested in shorter period, could it be e.g. last month/week by default?


Version - 0.9.0
Comment 1 Dan Callaghan 2012-07-12 20:30:47 EDT
The code renders the same number of points in the graph no matter what date range is selected. Its slowness is correlated with number of systems in the data set, not date range. Unfortunately there is just no way to efficiently produce the data needed from Beaker's db schema.

The best approach is probably to abandon it altogether and use Graphite or some other time series data store instead:

http://gerrit.beaker-project.org/#/c/599/
Comment 2 Nick Coghlan 2012-12-06 22:43:48 EST
I think we should include some *documented* recommendations for the metrics stuff we're farming out to Jasper and Graphite.

For this one, since the code to send notifications to Graphite is already in place, we can just recheck it this release cycle.

However, we should also figure out some specific suggestions for Graphite links to add via the external reference feature being added in #883606 and include those in the documentation. This can be part of the documentation of the Graphite support in the Admin Guide, which I don't believe exists yet...
Comment 3 Dan Callaghan 2012-12-12 01:59:03 EST
Docs for Graphite integration:
http://gerrit.beaker-project.org/1555

System utilisation metrics, to match up with the existing SQL-based utilisation graph (the original complaint in this bug):
http://gerrit.beaker-project.org/1556
Comment 5 Dan Callaghan 2012-12-20 01:19:46 EST
Suggested URL in the docs was wrong:

http://gerrit.beaker-project.org/1588
Comment 6 Raymond Mancy 2013-01-02 01:53:51 EST
Can't really verify docs until they are on a website somewhere, and cannot verify graphite metrics until they are being sent.
Comment 7 Raymond Mancy 2013-01-02 18:51:10 EST
Built website (incl docs) locally, verified metrics on personal graphite server.
Comment 8 Dan Callaghan 2013-01-16 23:34:37 EST
Beaker 0.11.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.