Bug 839596 - GDB crashes while parsing Xorg coredump
GDB crashes while parsing Xorg coredump
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 08:03 EDT by Zdenek Kabelac
Modified: 2012-07-15 04:42 EDT (History)
5 users (show)

See Also:
Fixed In Version: gdb-7.4.50.20120714-14.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-15 04:42:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
coredump bt when answering 'y' (30.71 KB, text/plain)
2012-07-12 08:03 EDT, Zdenek Kabelac
no flags Details
coredump when answering 'n' (10.03 KB, text/plain)
2012-07-12 08:04 EDT, Zdenek Kabelac
no flags Details
coredump (5.89 MB, application/octet-stream)
2012-07-13 07:18 EDT, Zdenek Kabelac
no flags Details
intel SNA driver used with this Xorg (2.41 MB, application/octet-stream)
2012-07-13 07:19 EDT, Zdenek Kabelac
no flags Details

  None (edit)
Description Zdenek Kabelac 2012-07-12 08:03:05 EDT
Description of problem:

My current coredumps generated by Xorg xorg-x11-server-1.12.2-3.fc18
are leading to coredump  (see Bug 839565)

A problem internal to GDB has been detected,
further debugging may prove unreliable.
Quit this debugging session? (y or n) 


It basically doesn't matter when I answer y/n - in both cases
coredump happens - though logs seems to be different.

I've no idea whether debuginfo for Xorg is broken.

Version-Release number of selected component (if applicable):
gdb-7.4.50.20120703-12.fc18.x86_64

How reproducible:


Steps to Reproduce:
1. gdb /usr/bin/Xorg /tmp/core.X.#####
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Zdenek Kabelac 2012-07-12 08:03:50 EDT
Created attachment 597780 [details]
coredump bt  when answering 'y'
Comment 2 Zdenek Kabelac 2012-07-12 08:04:25 EDT
Created attachment 597782 [details]
coredump when answering 'n'
Comment 3 Jan Kratochvil 2012-07-12 10:09:34 EDT
The Xorg core file really is not available?
Comment 4 Zdenek Kabelac 2012-07-13 05:14:53 EDT
No in both cases the core file for Xorg and approriate  debuginfo packages were present on my system.

After downgrade to these packages:

$ rpm -qa | grep xorg-x11-server
392196 xorg-x11-server-utils-7.5-12.fc18.x86_64
1612042 xorg-x11-server-Xnest-1.12.2-3.fc18.x86_64
3373920 xorg-x11-server-Xorg-1.12.2-3.fc18.x86_64
134431 xorg-x11-server-common-1.12.2-3.fc18.x86_64
1400045 xorg-x11-server-devel-1.12.2-3.fc18.x86_64
1807361 xorg-x11-server-Xvfb-1.12.2-3.fc18.x86_64
74015846 xorg-x11-server-debuginfo-1.12.2-3.fc18.x86_64


I'm able to get the core dump from crashing Xorg without any problems.
However newer version of Xorg  packages seems to confuse gdb.
I'm not really sure where is the fault - possible wrong debuginfo package for Xorg, however  gdb should not probably generate coredump in this case anyway.
Comment 5 Zdenek Kabelac 2012-07-13 07:18:56 EDT
Created attachment 598043 [details]
coredump
Comment 6 Zdenek Kabelac 2012-07-13 07:19:48 EDT
Created attachment 598044 [details]
intel SNA driver used with this Xorg
Comment 7 Jan Kratochvil 2012-07-13 08:04:18 EDT
I believe invalid DWARF is either in
  /home/kabi/soft/glx-test/lib/xorg/modules/drivers/intel_drv.so
or in:
  /home/kabi/soft/glx-test/lib/libdrm_intel.so.1
Please attach these, thanks.
Comment 8 Jan Kratochvil 2012-07-13 08:13:05 EDT
/home/kabi/soft/glx-test/lib/xorg/modules/drivers/intel_drv.so is the Comment 6 attachment.

Note You need to log in before you can comment on or make changes to this bug.