Bug 839600 - FTBFS perl-Class-InsideOut-1.10-7.fc18
FTBFS perl-Class-InsideOut-1.10-7.fc18
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: perl-Class-InsideOut (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
https://koji.fedoraproject.org/koji/t...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 08:12 EDT by Petr Pisar
Modified: 2012-08-01 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 00:20:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 77860 None None None 2012-07-12 08:12:45 EDT

  None (edit)
Description Petr Pisar 2012-07-12 08:12:45 EDT
perl-Class-InsideOut-1.10-7.fc18 fails to build in F18:

Executing(%check): /bin/sh -e /var/tmp/rpm-tmp.rsdG1H
+ umask 022
+ cd /builddir/build/BUILD
+ cd Class-InsideOut-1.10
+ unset DISPLAY
+ make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/01_load.t ........................ ok
t/02_register.t .................... ok
t/03_properties.t .................. ok
t/04_threaded.t .................... ok
t/05_forking.t ..................... ok
t/06_export_ok.t ................... ok
t/07_synopsis_obj.t ................ ok
t/08_DEMOLISH.t .................... ok
t/09_foreign.t ..................... ok
t/10_storable_values.t ............. ok
t/11_storable_refs.t ............... ok
t/12_storable_hooks.t .............. ok
t/13_options.t ..................... ok
t/14_accessor_hooks.t .............. ok
#   Failed test 'require t::Object::Trivial succeeded without XS'
#   at t/15_no_weaken_fallback.t line 52.
#          got: 'Died at t/15_no_weaken_fallback.t line 30.
# Compilation failed in require at /usr/lib64/perl5/vendor_perl/Scalar/Util.pm line 11.
# Compilation failed in require at /builddir/build/BUILD/Class-InsideOut-1.10/blib/lib/Class/InsideOut.pm line 20.
# BEGIN failed--compilation aborted at /builddir/build/BUILD/Class-InsideOut-1.10/blib/lib/Class/InsideOut.pm line 20.
# Compilation failed in require at t/Object/Trivial.pm line 4.
# BEGIN failed--compilation aborted at t/Object/Trivial.pm line 4.
# Compilation failed in require at (eval 4) line 2.
# '
#     expected: ''
#   Failed test 'caught a warning'
#   at t/15_no_weaken_fallback.t line 55.
Use of uninitialized value $this in pattern match (m//) at t/15_no_weaken_fallback.t line 56.
#   Failed test 'Saw warning for Scalar::Util::weaken unavailable'
#   at t/15_no_weaken_fallback.t line 56.
#                   undef
#     doesn't match '/Scalar::Util::weaken/'
# Looks like you failed 3 tests of 3.
t/15_no_weaken_fallback.t .......... 
Dubious, test returned 3 (wstat 768, 0x300)
Failed 3/3 subtests 
t/16_property_argument_checking.t .. ok
t/17_option_argument_checking.t .... ok
t/18_register_argument_checking.t .. ok
t/19_storable_singleton.t .......... ok
t/20_storable_singleton_error.t .... ok
t/21_optional_new.t ................ ok
t/22_readonly.t .................... ok
Test Summary Report
-------------------
t/15_no_weaken_fallback.t        (Wstat: 768 Tests: 3 Failed: 3)
  Failed tests:  1-3
  Non-zero exit status: 3
Files=22, Tests=383,  1 wallclock secs ( 0.12 usr  0.05 sys +  0.76 cusr  0.15 csys =  1.08 CPU)
Result: FAIL
Failed 1/22 test programs. 3/383 subtests failed.
make: *** [test_dynamic] Error 255


This is due to incompatibilities with Scalar-List-Utils-1.25, reported to upstream <https://rt.cpan.org/Public/Bug/Display.html?id=77860>.
Comment 1 Ralf Corsepius 2012-08-01 00:20:43 EDT
Closing, perl-Class-InsideOut was retired rawhide/F18.

Note You need to log in before you can comment on or make changes to this bug.