Bug 839602 - FTBFS libprelude-1.0.0-13.fc18
Summary: FTBFS libprelude-1.0.0-13.fc18
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libprelude (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://koji.fedoraproject.org/koji/t...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-12 12:19 UTC by Petr Pisar
Modified: 2012-08-08 12:50 UTC (History)
1 user (show)

Fixed In Version: libprelude-1.0.0-15.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 12:50:44 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix from gnulib (2.83 KB, patch)
2012-08-08 12:27 UTC, Petr Pisar
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 821772 None None None Never

Description Petr Pisar 2012-07-12 12:19:43 UTC
libprelude-1.0.0-13.fc18 fails to build in F18:

make[4]: Entering directory `/builddir/build/BUILD/libprelude-1.0.0/libmissing'
/bin/sh ../libtool --tag=CC   --mode=compile gcc -std=gnu99 -DHAVE_CONFIG_H -DNO_XMALLOC -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -c -o c-ctype.lo c-ctype.c
/bin/sh ../libtool --tag=CC   --mode=compile gcc -std=gnu99 -DHAVE_CONFIG_H -DNO_XMALLOC -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -c -o close-hook.lo close-hook.c
/bin/sh ../libtool --tag=CC   --mode=compile gcc -std=gnu99 -DHAVE_CONFIG_H -DNO_XMALLOC -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -c -o localcharset.lo localcharset.c
/bin/sh ../libtool --tag=CC   --mode=compile gcc -std=gnu99 -DHAVE_CONFIG_H -DNO_XMALLOC -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -c -o printf-frexp.lo printf-frexp.c
libtool: compile:  gcc -std=gnu99 -DHAVE_CONFIG_H -DNO_XMALLOC -I. -I.. -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -c c-ctype.c  -fPIC -DPIC -o .libs/c-ctype.o
libtool: compile:  gcc -std=gnu99 -DHAVE_CONFIG_H -DNO_XMALLOC -I. -I.. -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -c close-hook.c  -fPIC -DPIC -o .libs/close-hook.o
libtool: compile:  gcc -std=gnu99 -DHAVE_CONFIG_H -DNO_XMALLOC -I. -I.. -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -c localcharset.c  -fPIC -DPIC -o .libs/localcharset.o
libtool: compile:  gcc -std=gnu99 -DHAVE_CONFIG_H -DNO_XMALLOC -I. -I.. -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -c printf-frexp.c  -fPIC -DPIC -o .libs/printf-frexp.o
In file included from localcharset.c:28:0:
./stdio.h:143:1: error: 'gets' undeclared here (not in a function)

This is due to undefined `gets' in bundled header file.

Comment 1 Petr Pisar 2012-08-02 15:02:33 UTC
See <http://permalink.gmane.org/gmane.comp.lib.gnulib.bugs/30298> for gnulib fix.

Comment 2 Petr Pisar 2012-08-08 12:27:28 UTC
Created attachment 603010 [details]
Fix from gnulib

Comment 3 Petr Pisar 2012-08-08 12:50:44 UTC
Fixed as libprelude-1.0.0-15.fc18 in F18.


Note You need to log in before you can comment on or make changes to this bug.