Bug 839604 - FTBFS gpsdrive-2.11-12.fc18
FTBFS gpsdrive-2.11-12.fc18
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gpsdrive (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
https://koji.fedoraproject.org/koji/t...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 08:25 EDT by Petr Pisar
Modified: 2012-07-30 04:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: gpsdrive-2.11-13.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-30 04:39:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-07-12 08:25:43 EDT
gpsdrive-2.11-12.fc18 does not build in F18:

DEBUG util.py:257:  Getting requirements for gpsdrive-2.11-12.fc18.src
DEBUG util.py:257:   --> gtk2-devel-2.24.10-2.fc18.x86_64
DEBUG util.py:257:   --> gettext-0.18.1.1-13.fc18.x86_64
DEBUG util.py:257:   --> intltool-0.50.2-2.fc18.noarch
DEBUG util.py:257:   --> desktop-file-utils-0.20-1.fc18.x86_64
DEBUG util.py:257:   --> pcre-devel-8.31-0.1.RC1.fc18.x86_64
DEBUG util.py:257:   --> autoconf-2.69-2.fc18.noarch
DEBUG util.py:257:   --> m4-1.4.16-4.fc18.x86_64
DEBUG util.py:257:   --> cmake-2.8.9-0.1.rc1.fc18.x86_64
DEBUG util.py:257:   --> libxml2-devel-2.8.0-1.fc18.x86_64
DEBUG util.py:257:   --> 1:libgda-devel-4.2.12-3.fc18.x86_64
DEBUG util.py:257:   --> boost-devel-1.48.0-16.fc18.x86_64
DEBUG util.py:257:   --> sqlite-devel-3.7.13-1.fc18.x86_64
DEBUG util.py:257:   --> libicu-devel-49.1.1-3.fc18.x86_64
DEBUG util.py:257:   --> libtool-ltdl-devel-2.4.2-4.fc18.x86_64
DEBUG util.py:257:   --> Already installed : 4:perl-devel-5.16.0-225.fc18.x86_64
DEBUG util.py:257:   --> libcurl-devel-7.26.0-4.fc18.x86_64
DEBUG util.py:257:   --> compat-libgda-devel-3.1.2-7.fc17.x86_64
DEBUG util.py:257:   --> gpsd-devel-3.5-1.fc18.x86_64
DEBUG util.py:257:   --> speech-dispatcher-devel-0.7.1-7.fc17.x86_64
DEBUG util.py:257:   --> postgresql-devel-9.1.4-2.fc18.x86_64
DEBUG util.py:257:  Package db4-devel is obsoleted by libdb4-devel, but obsoleting package does not provide for requirements
DEBUG util.py:257:  Package db4-devel is obsoleted by libdb4-devel, but obsoleting package does not provide for requirements
DEBUG util.py:257:  Package db4-devel is obsoleted by libdb4-devel, but obsoleting package does not provide for requirements
DEBUG util.py:257:  Package db4-devel is obsoleted by libdb4-devel, but obsoleting package does not provide for requirements
DEBUG util.py:257:  Package db4-devel is obsoleted by libdb4-devel, but obsoleting package does not provide for requirements
DEBUG util.py:257:  Package db4-devel is obsoleted by libdb4-devel, but obsoleting package does not provide for requirements
DEBUG util.py:257:  Error: Package: compat-libgda-devel-3.1.2-7.fc17.x86_64 (build)
DEBUG util.py:257:             Requires: db4-devel
DEBUG util.py:257:             Available: db4-devel-4.8.30-10.fc18.x86_64 (build)
DEBUG util.py:257:                 db4-devel = 4.8.30-10.fc18


This is due to build-time dependencies conflict: compat-libgda-devel pulls obsolete libdb4-devel in.
Comment 1 Kevin Fenzi 2012-07-13 14:39:32 EDT
So, adding the compat-libgda maintainer here for comment...
Comment 2 Gwyn Ciesla 2012-07-19 22:54:43 EDT
compat-libgda has now been rebuild with libdb-devel instead, have a go once rawhide mashes again.
Comment 3 Jitka Plesnikova 2012-07-30 04:39:21 EDT
The gpsdrive was successfully rebuild with updated dependencies.

Note You need to log in before you can comment on or make changes to this bug.