Bug 839607 - FTBFS libpreludedb-1.0.0-11.fc18
FTBFS libpreludedb-1.0.0-11.fc18
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libpreludedb (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
https://koji.fedoraproject.org/koji/t...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 08:30 EDT by Petr Pisar
Modified: 2012-08-08 08:58 EDT (History)
1 user (show)

See Also:
Fixed In Version: libpreludedb-1.0.0-13.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 08:58:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix from gnulib (2.83 KB, patch)
2012-08-08 08:45 EDT, Petr Pisar
no flags Details | Diff

  None (edit)
Description Petr Pisar 2012-07-12 08:30:00 EDT
libpreludedb-1.0.0-11.fc18 fails to build in F18:

make[4]: Entering directory `/builddir/build/BUILD/libpreludedb-1.0.0/libmissing'
/bin/sh ../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m64 -mtune=generic -c -o asnprintf.lo asnprintf.c
/bin/sh ../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m64 -mtune=generic -c -o printf-args.lo printf-args.c
/bin/sh ../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m64 -mtune=generic -c -o printf-parse.lo printf-parse.c
/bin/sh ../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m64 -mtune=generic -c -o vasnprintf.lo vasnprintf.c
/bin/sh ../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m64 -mtune=generic -c -o glthread/lock.lo glthread/lock.c
/bin/sh ../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m64 -mtune=generic -c -o glthread/threadlib.lo glthread/threadlib.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -c asnprintf.c  -fPIC -DPIC -o .libs/asnprintf.o
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -c printf-args.c  -fPIC -DPIC -o .libs/printf-args.o
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -c printf-parse.c  -fPIC -DPIC -o .libs/printf-parse.o
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -c vasnprintf.c  -fPIC -DPIC -o .libs/vasnprintf.o
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -c glthread/threadlib.c  -fPIC -DPIC -o glthread/.libs/threadlib.o
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -c glthread/lock.c  -fPIC -DPIC -o glthread/.libs/lock.o
In file included from ./wchar.h:63:0,
                 from printf-args.h:42,
                 from printf-parse.h:26,
                 from printf-parse.c:37:
./stdio.h:143:1: error: 'gets' undeclared here (not in a function)


This is due to undefined `gets' in bundled header file.
Comment 1 Petr Pisar 2012-08-02 11:02:38 EDT
See <http://permalink.gmane.org/gmane.comp.lib.gnulib.bugs/30298> for gnulib fix.
Comment 2 Petr Pisar 2012-08-08 08:45:58 EDT
Created attachment 603014 [details]
Fix from gnulib
Comment 3 Petr Pisar 2012-08-08 08:58:42 EDT
Fixed as libpreludedb-1.0.0-13.fc18 in F18.

Note You need to log in before you can comment on or make changes to this bug.