Bug 839609 - FTBFS perl-eperl-2.2.14-20.fc18
Summary: FTBFS perl-eperl-2.2.14-20.fc18
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-eperl   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steven Pritchard
QA Contact: Fedora Extras Quality Assurance
URL: https://koji.fedoraproject.org/koji/t...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-12 12:35 UTC by Petr Pisar
Modified: 2012-08-06 08:49 UTC (History)
3 users (show)

Fixed In Version: perl-eperl-2.2.14-22.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-06 08:49:58 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for perl 5.16 changes (400 bytes, patch)
2012-07-30 07:47 UTC, Jitka Plesnikova
no flags Details | Diff

Description Petr Pisar 2012-07-12 12:35:41 UTC
perl-eperl-2.2.14-20.fc18 fails to build in F18:

In file included from eperl_perl5.c:38:0:
eperl_perl5.h:76:0: warning: "PL_defoutgv" redefined [enabled by default]
In file included from /usr/lib64/perl5/CORE/perl.h:5038:0,
                 from eperl_perl5.h:43,
                 from eperl_perl5.c:38:
/usr/lib64/perl5/CORE/embedvar.h:149:0: note: this is the location of the previous definition
eperl_perl5.c: In function 'Perl5_ForceUnbufferedStdout':
eperl_perl5.c:84:5: error: 'defoutgv' undeclared (first use in this function)


This is not compatible with perl 5.16.0.

Comment 1 Jitka Plesnikova 2012-07-30 07:46:44 UTC
The problem is that the macro WITH_THX is not defined in perl 5.16. The definition was removed from malloc.c.

The possible solution is in the attachment. Also the build require needs to replace db4-devel by libdb-devel.

Comment 2 Jitka Plesnikova 2012-07-30 07:47:23 UTC
Created attachment 601139 [details]
Patch for perl 5.16 changes

Comment 3 Marcela Mašláňová 2012-08-06 08:49:58 UTC
Steven,
I applied the patch. I hope you don't mind.


Note You need to log in before you can comment on or make changes to this bug.