Bug 839610 - FTBFS openscap-0.8.2-2.fc18
Summary: FTBFS openscap-0.8.2-2.fc18
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openscap   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Lautrbach
QA Contact: Fedora Extras Quality Assurance
URL: https://koji.fedoraproject.org/koji/t...
Whiteboard:
Keywords:
Depends On: 841245
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-12 12:40 UTC by Petr Pisar
Modified: 2012-08-01 08:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 08:13:11 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Petr Pisar 2012-07-12 12:40:12 UTC
openscap-0.8.2-2.fc18 fails to build in F18:

make[4]: Entering directory `/builddir/build/BUILD/openscap-0.8.2/lib'
  CC     dummy.lo
/bin/sh ../libtool --silent --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -fpie -pipe -std=c99 -W -Wall -Wnonnull -Wshadow -Wformat -Wundef -Wno-unused-parameter -Wmissing-prototypes -Wno-unknown-pragmas -D_GNU_SOURCE -DOSCAP_THREAD_SAFE -D_POSIX_C_SOURCE=200112L  -march=i686 -DNDEBUG -Wno-unused-function -c -o dummy.lo dummy.c
  CC     asnprintf.lo
/bin/sh ../libtool --silent --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -fpie -pipe -std=c99 -W -Wall -Wnonnull -Wshadow -Wformat -Wundef -Wno-unused-parameter -Wmissing-prototypes -Wno-unknown-pragmas -D_GNU_SOURCE -DOSCAP_THREAD_SAFE -D_POSIX_C_SOURCE=200112L  -march=i686 -DNDEBUG -Wno-unused-function -c -o asnprintf.lo asnprintf.c
  CC     printf-args.lo
/bin/sh ../libtool --silent --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -fpie -pipe -std=c99 -W -Wall -Wnonnull -Wshadow -Wformat -Wundef -Wno-unused-parameter -Wmissing-prototypes -Wno-unknown-pragmas -D_GNU_SOURCE -DOSCAP_THREAD_SAFE -D_POSIX_C_SOURCE=200112L  -march=i686 -DNDEBUG -Wno-unused-function -c -o printf-args.lo printf-args.c
  CC     printf-parse.lo
/bin/sh ../libtool --silent --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -fpie -pipe -std=c99 -W -Wall -Wnonnull -Wshadow -Wformat -Wundef -Wno-unused-parameter -Wmissing-prototypes -Wno-unknown-pragmas -D_GNU_SOURCE -DOSCAP_THREAD_SAFE -D_POSIX_C_SOURCE=200112L  -march=i686 -DNDEBUG -Wno-unused-function -c -o printf-parse.lo printf-parse.c
  CC     vasnprintf.lo
/bin/sh ../libtool --silent --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -fpie -pipe -std=c99 -W -Wall -Wnonnull -Wshadow -Wformat -Wundef -Wno-unused-parameter -Wmissing-prototypes -Wno-unknown-pragmas -D_GNU_SOURCE -DOSCAP_THREAD_SAFE -D_POSIX_C_SOURCE=200112L  -march=i686 -DNDEBUG -Wno-unused-function -c -o vasnprintf.lo vasnprintf.c
vasnprintf.c:63:6: warning: "WIDE_CHAR_VERSION" is not defined [-Wundef]
In file included from vasnprintf.c:66:0:
vasnprintf.h:67:5: warning: "REPLACE_VASNPRINTF" is not defined [-Wundef]
In file included from asnprintf.c:21:0:
vasnprintf.h:67:5: warning: "REPLACE_VASNPRINTF" is not defined [-Wundef]
In file included from printf-args.c:30:0:
printf-args.h:83:5: warning: "ENABLE_UNISTDIO" is not defined [-Wundef]
printf-args.h:128:5: warning: "ENABLE_UNISTDIO" is not defined [-Wundef]
printf-args.c: In function 'printf_fetchargs':
printf-args.c:144:5: warning: "ENABLE_UNISTDIO" is not defined [-Wundef]
In file included from vasnprintf.c:71:0:
./stdio.h:1048:1: error: 'gets' undeclared here (not in a function)


This is due to undefined `gets' in bundled header file.

Comment 1 Petr Lautrbach 2012-07-17 13:53:28 UTC
Rawhide build probably needs to backport bbd12ad5be79ebbc792f5af3f7581803d53d146f commit - gnulib update

Comment 2 Petr Lautrbach 2012-07-18 13:44:18 UTC
There is also an issue with swig:

In file included from ../src/common/public/oscap.h:37:0,
                 from openscap_pm_wrap.c:1799:
../src/common/public/text.h: At top level:
../src/common/public/text.h:123:1: error: unknown type name 'bool'
../src/common/public/text.h:128:1: error: unknown type name 'bool'


Note You need to log in before you can comment on or make changes to this bug.