Bug 839618 - FTBFS perl-Hardware-Vhdl-Parser-0.12-11.fc18
FTBFS perl-Hardware-Vhdl-Parser-0.12-11.fc18
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Hardware-Vhdl-Parser (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
https://koji.fedoraproject.org/koji/t...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 08:53 EDT by Petr Pisar
Modified: 2012-11-06 03:02 EST (History)
1 user (show)

See Also:
Fixed In Version: perl-Hardware-Vhdl-Parser-0.12-13.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 03:02:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 77946 None None None 2012-07-12 08:53:46 EDT

  None (edit)
Description Petr Pisar 2012-07-12 08:53:45 EDT
perl-Hardware-Vhdl-Parser-0.12-11.fc18 fails to build in F18:

Executing(%check): /bin/sh -e /var/tmp/rpm-tmp.zJTaEr
+ umask 022
+ cd /builddir/build/BUILD
+ cd Hardware-Vhdl-Parser-0.12
+ unset DISPLAY
+ make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-Iblib/lib" "-Iblib/arch" test.pl
1..2
ok 1
                ERROR: Production signal_declaration for
                       "entity_declaritive_item" will never be reached
                       (preceding empty production will always match first).
                 Hint: Set $::RD_HINT (or -RD_HINT if you're using "perl -s")
                       for hints on fixing these problems. Use $::RD_HINT = 0
                       to disable this message.
Can't bless non-reference value at blib/lib/Hardware/Vhdl/Parser.pm line 40.
make: *** [test_dynamic] Error 255

Tests fail due to incompatibility with perl-Parse-RecDescent-1.967006 and newer. They pass with perl-Parse-RecDescent-1.967003. Reported to upstream <https://rt.cpan.org/Public/Bug/Display.html?id=77946>.
Comment 1 Petr Pisar 2012-11-06 03:02:18 EST
This has been fixed by shakthimaan with disabling tests.

Note You need to log in before you can comment on or make changes to this bug.