Bug 839623 - FTBFS xchat-gnome-0.26.2-7.git40c5bf988.fc18
FTBFS xchat-gnome-0.26.2-7.git40c5bf988.fc18
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xchat-gnome (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
https://koji.fedoraproject.org/koji/t...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 08:58 EDT by Petr Pisar
Modified: 2014-03-16 23:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-12 12:10:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-07-12 08:58:32 EDT
xchat-gnome-0.26.2-7.git40c5bf988.fc18 fails to build in F18:

CCLD   xchat-gnome
/usr/bin/ld: ../../src/libeggsmclient/.libs/libeggsmclient.a(eggsmclient-xsmp.o): undefined reference to symbol 'IceProcessMessages'
/usr/bin/ld: note: 'IceProcessMessages' is defined in DSO /lib64/libICE.so.6 so try adding it to the linker command line
/lib64/libICE.so.6: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status

It fails to link because of undefined reference to symbol `IceProcessMessages'. It must link to /lib/libICE.so.6 explicitly.
Comment 1 Bill Nottingham 2012-07-12 12:10:32 EDT
Fixed (wasn't the only lib)

Note You need to log in before you can comment on or make changes to this bug.