Bug 839651 - FTBFS perl-PDL-2.4.10-2.fc18
FTBFS perl-PDL-2.4.10-2.fc18
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-PDL (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
https://koji.fedoraproject.org/koji/t...
:
: 992700 (view as bug list)
Depends On:
Blocks: 828229 F20FTBFS
  Show dependency treegraph
 
Reported: 2012-07-12 09:43 EDT by Petr Pisar
Modified: 2013-11-19 09:10 EST (History)
4 users (show)

See Also:
Fixed In Version: perl-PDL-2.4.10-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 18:50:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-07-12 09:43:47 EDT
perl-PDL-2.4.10-2.fc18 fails to build in F18:

/usr/bin/perl /usr/share/perl5/ExtUtils/xsubpp  -typemap /usr/share/perl5/ExtUtils/typemap -typemap /builddir/build/BUILD/PDL-2.4.10/Basic/Core/typemap.pdl  Proj.xs > Proj.xsc && mv Proj.xsc Proj.c
cp Proj.pm ../../../blib/lib/PDL/GIS/Proj.pm
gcc -c  -I/builddir/build/BUILD/PDL-2.4.10/Basic/Core -I/usr/include -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -Wno-unused   -DVERSION=\"1.32\" -DXS_VERSION=\"1.32\" -fPIC "-I/usr/lib/perl5/CORE"   Proj.c
Proj.xs:21:22: fatal error: projects.h: No such file or directory
compilation terminated.
make[3]: *** [Proj.o] Error 1


This is due incompatibility with proj-4.8.0 which moved projects.h. Reported to upstream <https://sourceforge.net/tracker/index.php?func=detail&aid=3515759&group_id=612&atid=100612>.

The newer 2.4.11 version is still affected.
Comment 1 Petr Pisar 2012-09-04 08:47:32 EDT
Upstream cannot resolve this issue in time. I will disable the Proj support in perl-PDL.
Comment 2 Fedora Update System 2012-09-04 09:04:58 EDT
perl-PDL-2.4.10-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-PDL-2.4.10-4.fc18
Comment 3 Fedora Update System 2012-09-04 12:54:09 EDT
Package perl-PDL-2.4.10-4.fc18, perl-PDL-Graphics-PLplot-0.59-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-PDL-2.4.10-4.fc18 perl-PDL-Graphics-PLplot-0.59-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13292/perl-PDL-2.4.10-4.fc18,perl-PDL-Graphics-PLplot-0.59-3.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-09-17 18:50:43 EDT
perl-PDL-2.4.10-4.fc18, perl-PDL-Graphics-PLplot-0.59-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Petr Pisar 2013-11-19 09:10:45 EST
*** Bug 992700 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.