Bug 839664 - Improve syslog message when configuration cannot be loaded
Improve syslog message when configuration cannot be loaded
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Hrozek
Kaushik Banerjee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 10:06 EDT by Stephen Gallagher
Modified: 2015-03-19 02:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: sssd-1.10.0-18.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-05 05:26:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2012-07-12 10:06:15 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/1414

The sss_log message we emit when configuration can't be loaded does not include the reason why. We might want to include error and strerror(errno) there.
Comment 2 Jakub Hrozek 2013-07-31 06:11:55 EDT
The enhancement was contributed by a community member during the 1.10 timeframe.
Comment 5 Kaushik Banerjee 2015-01-12 05:31:54 EST
Verified in version sssd-1.12.2-39.el7

/var/log/messages now shows:
Jan 12 15:57:41 testmachine sssd: SSSD couldn't load the configuration database [5]: Input/output error.
Comment 7 errata-xmlrpc 2015-03-05 05:26:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0441.html

Note You need to log in before you can comment on or make changes to this bug.