Bug 839670 - RFE - Notifications with id of request that caused it
RFE - Notifications with id of request that caused it
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
urgent Severity low (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Og Maciel
: FutureFeature, TestBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 10:11 EDT by Jeff Weiss
Modified: 2014-11-09 17:52 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 15:31:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2012-07-12 10:11:41 EDT
Description of problem:
Currently it is impossible to reliably determine whether an automated test passed.  Example.  

The test is, create an org with a blank name, and verify that an error message pops up saying that is not allowed.

So the automation creates a new org, clicks submit, and there is a notification saying "Sync completed successfully:  foorepo".  

That notification had *nothing* to do with the test, it just happened to pop up at the wrong time.  We know that, but the automation has no way of knowing.  It just knows it was supposed to get a red notification and it got a green one.

Even trying to match the content of the notification doesn't work.  It's impossible for automation to tell the difference between some cryptic error it's never seen before that's caused directly by what it's testing, and some cryptic async error that has nothing to do with what it is testing.

Proposed solution:
Each rest action should return an id somewhere in the HTML, and every notification that results from that action should contain the same id.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Brad Buckingham 2012-08-01 13:45:44 EDT
There is one piece of information available in a notice that is rendered that may be useful if trying to associate a notice with a given action performed by the user.

For each notice, katello stores the 'request_type' and passes it back to the client when the notice is delivered. This request type consists of a combination of the controller (e.g. changesets) and the action (e.g. promote) that is being performed.  When the notice is rendered, it will be included as a class on the notice.  For example:
  <ul class="changesets___promote">

This may help; however, if using this example, we scheduled 3 different promotions and received the notices for all of them at the same time, we would not be able to correlate them, other than to look in to the actual text message that comes back. 

If using the action_type is not sufficient, we can certainly look at other solutions to expand the information stored/returned with a notice.
Comment 5 Tom McKay 2012-10-24 15:31:39 EDT
Testing automation has switched to using javascript to track incoming notices
Comment 6 Mike McCune 2013-08-16 14:08:03 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.