Bug 839696 - Systemd package assumes authconfig manages pam, etc...
Systemd package assumes authconfig manages pam, etc...
Status: CLOSED DUPLICATE of bug 820483
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 10:56 EDT by Jason Smith
Modified: 2012-07-12 11:23 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-12 11:23:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Smith 2012-07-12 10:56:32 EDT
Description of problem:
When the systemd package is updated, it assumes authconfig was used to configure pam and other auth config files and executes the authconfig command in the rpm %post. This will cause problems for anyone that is not using authconfig. We use puppet to manage all of our system config, not authconfig, so updating the systemd rpm will clobber our puppet configured /etc/pam.d/system-auth and break our system configs.

Version-Release number of selected component (if applicable):
It looks like this was introduced when trying to resolve bug #679517 which made the change in systemd-20-1.fc15.

How reproducible:
Always.

Steps to Reproduce:
1. Update the systemd rpm when Fedora releases a new update.
2. The %post script in the systemd rpm will execute authconfig if /etc/pam.d/system-auth is not a symlink or /etc/pam.d/system-auth-ac does not contain the pam_systemd module.
  
Actual results:
Since we use puppet to manage /etc/pam.d/system-auth on all of our systems, our puppet configured pam is clobbered. Because we use puppet, the /etc/pam.d/system-auth config file is managed by puppet and /etc/pam.d/system-auth-ac is not used on our systems.

Expected results:
The systemd rpm should not assume that everyone uses authconfig since there are other ways to manage system config files, so authconfig should not be executed in the rpm %post if authconfig was not used to configure the system in the first place.
Comment 1 Bill Nottingham 2012-07-12 11:18:11 EDT
This is fixed in F18.
Comment 2 Michal Schmidt 2012-07-12 11:23:36 EDT
Correct. We removed the authconfig calls from systemd scriptlets in F18.

I do not intend to change the scriptlets in F17.

See https://bugzilla.redhat.com/show_bug.cgi?id=820483#c1 for a possible workaround.

*** This bug has been marked as a duplicate of bug 820483 ***

Note You need to log in before you can comment on or make changes to this bug.