This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 839707 - xwd driver
xwd driver
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: ncl (Show other bugs)
el6
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 11:28 EDT by resler
Modified: 2012-08-05 02:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-05 02:40:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for xwd.c (756 bytes, patch)
2012-07-12 11:28 EDT, resler
no flags Details | Diff
Patch ready for applying (1.59 KB, patch)
2012-07-12 12:53 EDT, resler
no flags Details | Diff
Example cgm file (715.78 KB, image/cgm)
2012-07-13 03:27 EDT, resler
no flags Details
xwd image made by original ctrans (980.69 KB, image/x-xwindowdump)
2012-07-13 03:31 EDT, resler
no flags Details
xwd image made by patched ctrans (979.69 KB, image/x-xwindowdump)
2012-07-13 03:32 EDT, resler
no flags Details

  None (edit)
Description resler 2012-07-12 11:28:10 EDT
Created attachment 597832 [details]
Patch for xwd.c

Description of problem:
ctrans program don't work correctly for xwd raster driver in x86_64 environment. The problem causes struct XColor which has platform dependent length. The problem and its solution is described in:
http://www.ncarg.ucar.edu/ncarg-talk/2006/0000.html

Version-Release number of selected component (if applicable):
ncl 5.2.1-6, x86_64

How reproducible:
Use ctran with xwd raster driver.

Steps to Reproduce:
1. Create xwd file from cgm file:
ctrans -d xwd -res 640x480 xxx.cgm > xxx.xwd
2. Explore resulting raster image:
xwud -in ./xxx.xwd
  
Actual results:
The xwd image is broken.

Expected results:


Additional info:
I append a simple patch for ncarview/src/lib/libncarg_ras/xwd.c which solves the problem and which could be easily added to src.rpm.
Comment 1 Orion Poplawski 2012-07-12 12:12:56 EDT
Thanks, but please attach a diff made with "diff -u" so it can be applied with patch.
Comment 2 resler 2012-07-12 12:53:27 EDT
Created attachment 597852 [details]
Patch ready for applying

The correct patch file appended. Sorry for my mistake.
Comment 3 Orion Poplawski 2012-07-12 18:10:58 EDT
No worries, thanks a lot for the patch.  It appears that this may not be fixed upstream in ncl 6.1.0-beta even which seems suprising.  Could you attach a test cgm image as well?
Comment 4 resler 2012-07-13 03:27:36 EDT
Created attachment 597991 [details]
Example cgm file
Comment 5 resler 2012-07-13 03:31:46 EDT
Created attachment 597992 [details]
xwd image made by original ctrans
Comment 6 resler 2012-07-13 03:32:25 EDT
Created attachment 597993 [details]
xwd image made by patched ctrans
Comment 7 resler 2012-07-13 03:41:18 EDT
You are right. The problem has not been corrected for long time upstream. This causes all binary distributions are not useful if you work in x86_64 environment and you need xwd driver. NCAR prefers ps driver over xwd but ps driver has still some quirks and xwd driver seems to be more straightforward for many applications.
Comment 8 Fedora Update System 2012-07-13 17:28:14 EDT
ncl-6.0.0-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ncl-6.0.0-2.el6
Comment 9 Fedora Update System 2012-07-14 14:32:40 EDT
Package ncl-6.0.0-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing ncl-6.0.0-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-6393/ncl-6.0.0-2.el6
then log in and leave karma (feedback).
Comment 10 resler 2012-07-16 03:43:30 EDT
I confirm that ctrans from testing package works properly with xwd driver.
Comment 11 Fedora Update System 2012-07-19 18:35:02 EDT
Package ncl-6.0.0-3.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing ncl-6.0.0-3.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-6393/ncl-6.0.0-3.el6
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-08-05 02:40:32 EDT
ncl-6.0.0-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.