Bug 839729 - [RFE] SSSD should have a way to detect whther IPA server is capable of the extended operations
[RFE] SSSD should have a way to detect whther IPA server is capable of the ex...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd (Show other bugs)
7.0
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: SSSD Maintainers
Kaushik Banerjee
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 12:38 EDT by Dmitri Pal
Modified: 2015-04-24 07:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-24 07:37:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-07-12 12:38:36 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/1406

In some time in near future we will allow not installing all AD trust bits on every IPA server. This has an impact on SSSD. SSSD would have to detect whether the IPA server it talks to is capable of the extended operations. The logic should be adjusted in such a way that SSSD would not failover to working only with the servers that haму AD related bits but rather would detect and use AD enabled servers only for the specific AD trust related operations. For other operations the SSSD should continue using the standard failover logic.
Comment 2 Martin Kosek 2015-04-24 07:37:43 EDT
The upstream reported confirmed that this fix is no longer relevant. Closing the RHEL bug as well.

Note You need to log in before you can comment on or make changes to this bug.