Bug 839773 - Gluster conflicts with nfs mounts
Gluster conflicts with nfs mounts
Status: CLOSED DUPLICATE of bug 799244
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Vinayaga Raman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 15:29 EDT by optix2002
Modified: 2014-03-30 21:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 02:50:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description optix2002 2012-07-12 15:29:24 EDT
Description of problem:
NFS mounts fail with "kernel: svc: failed to register lockdv1 RPC service (errno 13)." when glusterd is started at boot.

Turning glusterd on boot and rebooting allows nfs mounts to work.

Alternatively, restarting the rpcbind service allows nfs mounts to work.

Version-Release number of selected component (if applicable):
3.3.0 on RHEL 6.2

How reproducible:
Most of the time



Steps to Reproduce:
1.Have glusterd run on startup
(Possibly with a volume and other nodes)
2.Try to mount an nfsv3 server.
3.mount fails, and logs give error
  
Actual results:
kernel: svc: failed to register lockdv1 RPC service (errno 13).

Expected results:
Mount succeeds

Additional info:
Disabling Gluster's NFS with nfs.disable on works.
Disabling nfs.register-with-portmap does not do anything to solve the iossue.
Comment 1 Rajesh 2012-07-13 02:50:12 EDT
its a known problem, as we have two programs contending for the same (program,version) duplet.

*** This bug has been marked as a duplicate of bug 799244 ***

Note You need to log in before you can comment on or make changes to this bug.