Bug 8398 - windows 2000 client can't access the Red Hat 5.2 + samba server
windows 2000 client can't access the Red Hat 5.2 + samba server
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-12 05:36 EST by vincentkuo
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-14 18:26:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vincentkuo 2000-01-12 05:36:20 EST
I used the Red Hat Linux with samba as the network server since Red Hat
5.0. I ever tried the Red Hat Linux 5.0, 5.1, 5.2, and 6.1. The samba
version which I'd ever tried are 2.0.3, 2.0.5a, and 2.0.6.
When I use the windows 2000 as the PC client to connect to the Linux
server. (samba server) The client will appear a failure message like "The
remote procedure call failure". But the windows 95, 98, NT 4.0 still can
work with the Linux server.

---> Test:
Client Type:
Windows 2000 Beta3 and Chinese Windows 2000 RC2
(version before Beta2 is OK)
(I don't know what the Microsoft had done something buggy!!)

   Server Platform              Result
------------------------------------------------------------
 Red Hat 5.2 + samba-2.0.3      Fail (The login box doesn't popup)
 Red Hat 5.2 + samba-2.0.5a     Fail (The login box popup once)
 Red Hat 6.0 + samba-2.0.5a     OK
 Red Hat 6.1 + samba-2.0.5a     OK
 Red Hat 6.1 + samba-2.0.6      OK
------------------------------------------------------------
1. The result OK means that I can use the windows 2000 client to access my
samba server when encrypt password enable. (plaintext password needs to
modify the window's registry)
2. At the same time, all of the windows 95/98/NT 4.0 clients could access
the server in any situation. (except windows 2000)

---> Compare:
The "Red Hat 5.2 + samba-2.0.5a" seems solved something from samba-2.0.3.
Because samba-2.0.3 will let the client popup failure message box at the
first time. The "Red Hat 5.2 + samba-2.0.5a" will appear the login
authentication box, after I keyin the username and password, the client
will appear a message box "The remote procedure call faulure" (Because the
message displayed in Chinese, I can't tell the exactly sentense in
English")

---> Compare:
I ever download the samba-2.0.5a for Red Hat 5.2 from the Errata FTP site.
And I compare it with the Red Hat 6.1 source CD (samba-2.0.5a), it the same
except some patch files which will be used in the RPM build procedure.

---> HELP!!
Because most of my servers are Red Hat 5.2, I want a solution for windows
2000 to access my server without upgrading to 6.1. Please find a solution
for me. Thanks!

If you got any solution, please email to me: "vincentkuo@netscape.net".

Vincent Kuo
Comment 1 Bill Nottingham 2000-01-13 10:40:59 EST
What kernel are you running on the 5.2 machines, and
what kernel did you build the binaries for 5.2 on?
(or are you using the standard Red Hat binaries?)

samba compiled on a glibc-2.x system that is running
a 2.1 kernel may not work on a 2.0 kernel, because it
will use system calls that aren't implemented in the
2.0 kernel.
Comment 2 vincentkuo 2000-01-16 22:45:59 EST
The kernel version is 2.0.36. (installed from the Red Hat 5.2)
I rebuild the samba binary from this machine. I used the SRPM from the Red Hat
FTP site (Errta FTP) "samba-2.0.5a-0.5.2.src.rpm" and I also rebuild the RPM
from the Red Hat 6.1 source CD "samba-s.0.5a-12.src.rpm". Both of them can't
be accessed by the Windows 2000.
My gcc version is 2.7.2.3 and my RPM version is 2.5.5. (They all are the default
packages from the Red Hat 5.2 installation.)

You wrote:
--> samba compiled on a glibc-2.x system that is running a 2.1 kernel may not
work on a 2.0 kernel, because it will use system calls that aren't implemented
in the 2.0 kernel.

--> Does it mean that there's no solution in kernel 2.0.36 to solve the windows
2000 problem?
Comment 3 Bill Nottingham 2000-01-18 11:34:59 EST
What happens if you turn on debugging output in the smb.conf file -
do the logs show what is failing when it tries to connect?
Comment 4 Bill Nottingham 2000-02-01 22:19:59 EST
Huh? I thought you mentioned earlier that it works with Windows 95/98.

Unfortunately, we don't have a Windows 2000 machine at the moment to
test against. You might be better off asking on one of the samba lists.
Comment 5 Bill Nottingham 2000-02-01 22:34:59 EST
Also, I would strongly suggest compiling samba-2.0.6 for your 5.2 systems
as well; it has some fixes for Win2K issues.
Comment 6 vincentkuo 2000-02-14 00:42:59 EST
Hi:
    I am sorry that I ever reply your mail before, but it didn't post (append)
here.
    1. There's no special warnings or error in the samba log when I turn the
debug level on.
    2. I ever read the samba's mail list and I'd already used the samba-2.0.6
for Red Hat Linux 5.2. I got a SRPM for samba-2.0.6 and I needed to rebuild it
under the RH 5.2. (kernel 2.0.36) But the problem is that there were some errors
during I rebuild the RPM. It seems need the kernel 2.2.x. Finally, I removed all
of the programs which related to the smbclient (ex. smbmount, smbumount,
mount.smbfs...) and the RPM cound build successfully.
    3. Because I use the samba as a SMB server, so it didn't impact my
enviroment and programs. But if anyone who want to use samba as a SMB client. My
method still doesn't solve the problem. So, need more info in the future.
Comment 7 vincentkuo 2000-02-14 00:44:59 EST
Sorry, I didn't memtion that the Red Hat 5.2 + Samba 2.0.6 could solve the
MS-Windows 2000 problem in the previous additional-comments. (Only when the
samba is a SMB Server)
Comment 8 Bill Nottingham 2000-02-14 18:26:59 EST
OK, then it's fixed in the current samba packages in rawhide.

Note You need to log in before you can comment on or make changes to this bug.