Bug 839815 - RFE: [PATCH] Add Miscellanea::RequireRcsKeywords, dropped from Perl-Critic
RFE: [PATCH] Add Miscellanea::RequireRcsKeywords, dropped from Perl-Critic
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Perl-Critic-More (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 19:10 EDT by Paul Howarth
Modified: 2013-10-29 06:21 EDT (History)
3 users (show)

See Also:
Fixed In Version: perl-Perl-Critic-More-1.000-6.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 05:05:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add Miscellanea::RequireRcsKeywords policy (7.06 KB, patch)
2012-07-12 19:10 EDT, Paul Howarth
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 69546 None None None 2012-07-12 19:10:19 EDT

  None (edit)
Description Paul Howarth 2012-07-12 19:10:19 EDT
Created attachment 597914 [details]
Add Miscellanea::RequireRcsKeywords policy

The Miscellanea::RequireRcsKeywords policy has been dropped from the core Perl-Critic distribution in version 1.118 and is on its way to joining Perl-Critic-More (see CPAN RT#69546). Since Perl-Critic 1.118 is now in Rawhide, that policy is currently unavailable in Rawhide. We could wait until Perl-Critic-More is updated but apparently upstream wants to do quite a bit of work on it before releasing an update.

In the meantime, it would be good to bundle the policy with the current release of Perl-Critic-More. The attached patch adds the policy and fixes up the test suite to expect its presence.
Comment 1 Petr Pisar 2012-07-13 04:33:49 EDT
That sounds reasonable. I will add it.
Comment 2 Petr Pisar 2013-10-29 06:21:32 EDT
The policy has been moved to Perl-Critic-Deprecated distribution at the end <http://cpansearch.perl.org/src/THALJEF/Perl-Critic-Deprecated-1.118/Changes>.

I will remove the patch from perl-Perl-Critic-More package and upgrade Perl-Critic-Deprecated (bug #1023708).

Note You need to log in before you can comment on or make changes to this bug.